Pixhawk arms and turns motor on QGroundControl but can not run motors with Pymavlink

Hello, I have an AUV and i am trying to run my AUV autonomously with pixhawk using ardusub firmware and pymavlink. Previously i was able to run motors both with QGroundControl and autonomous code with pymavlink, but suddenly my Pixhawk stopped running the motors with autonomous code using pymavlink and with joystick using QGroundControl.
Here i will share some specifications of my system.

  • Pixhawk 2.4.8 / RadioLink Pixhawk ( I tried with both of them).
  • Frame type: Vectored/BlueROV2
  • Firmware version: ChibiOS / Sub / Pixhawk1-4.1.0
  • Git Revision: f2af3fc7e
    All Safety options are disabled.
    Thrusters: T200
    ESC: BlueRobotics ESC

I am using manual control commands to move my AUV. Which i have tried previously in pool and it was working normally. I am using ‘STABILIZE’ mode.

Now when i run my python code to move motors, it says motors armed and the manual control function is worked but my thrusters doesnt move. But I am able to move my thrusters with QGroundControl on the motor page.
And also I can not run my motors with joystick which also i was able to run previously.

I tried to reset firmware of Pixhawk and reupload the parameters which i saved previously while my pixhawk working properly but it didnt help. Can you please help me? Thank you in advance.

Hi @enesyurt78, apologies for the delay on getting to this.

If that doesn’t help, can you please specify/provide the following:

  1. Which software version you’re running on the Onboard Computer
    • e.g. BlueOS 1.0.1, or Companion 0.0.31
  2. Which Python code you’re using to connect to and try to control the vehicle
  3. A copy of your vehicle parameters (which you can download as a file from QGroundControl)