Motors are not working

is this connection sill working with the blueos firmware. my motors are not working and the QGroundcontrol are having alters like “motor initialization failed”. what can i do to make my motors work. pease help.

Hi @jesselat -
Yes, that diagram still applies when using BlueOS in conjunction with Ardusub firmware, on either a Pixhawk or Navigator equipped BROV2.

Can you share a bit more context of your problem? Did you upgrade from companion to BlueOS, and now your motors don’t work? What version of BlueOS are you using? What version of Ardusub? Do you know what revision your BROV2 is?

I’d recommend testing the motors from QGroundControl or BlueOS web page interface, but not with both open. Also make sure you’ve selected the correct vehicle type and loaded it’s default parameters!

I am using the v 1.1.1 version of BlueOS and pixhawk firmware version: 4.1.1 (STABLE). The motors are working when I’m testing it in the vehicle setup page of the BlueOS but it is ow working when I’m controlling it with my joystick controller. What do you think is the problem?

Maybe the motors are not working because of this error in the wizard

. Can you please help me with this?

Hi @jesselat -
Not having an autopilot firmware on your device would definitely lead to issues! You should be able to install it manually from the BlueOS page Autopilot Firmware, with BlueOS connected to the internet. Are you using a Navigator or a Pixhawk?

For reference, once you have the motors responding to commands in manual mode, the QGroundControl motor control page is intended to determine motor direction automatically - but will fail to do so if the ROV is sitting on the ground. It needs to be in water to measure the motion that results when pulsing the thrusters, to properly set their direction.

The firmware for the pixhawk is already installed. The motors are responding to motor test in the BlueOS vehicle setup page. Its main function in moving underwater is not responding when I’m controlling it with my Logitech wireless controller.

Hi @jesselat -
Have you successfully enabled and calibrated your game controller with QGroundControl or Cockpit? Verified it works and is recognized with your computer using a tool like this?

It is already calibrated but still, nothing works

Is the joystick enabled (with the check box) under the General tab in QGC? Is the vehicle armed?

The joystick is already enabled and the vehicle is armed but there is no motor responding.

Hi @jesselat -
The first screenshot you shared is not where the joystick needs to be enabled. With the vehicle connected, click the Q icon and then select vehicle setup. The joystick menu there has the check box I’m referring too, and it by default isn’t checked until you’ve calibrated the joytsick. Sorry for the delayed response!