Home        Store        Docs        Blog

Immobile thruster during arm check


#1

Hello all,

I recently purchased a BlueROV2 and attempted to perform an arming check on it using MavProxy.
Upon performing the check, one of the propellers did not spin. To isolate the cause of the issue, I wired the ESC to one of the other propellers on the BlueROV2 and tried arming it again. The propeller still didn’t spin. I am beginning to suspect that it is an issue with the provided ESC. Any insight? Thank you.


(Jacob) #2

Can you provide more details like the commands you are entering into mavproxy, and the output in response to those commands? Not all commands in MAVProxy are supported by ArduSub, and arming checks are only supported in ArduSub 3.5+.

-Jacob


#3

Hello Jacob,

Thank you for replying. Apologies for the trouble; I just received word from my team that they actually used QGroundControl to try and arm the throttle, not MAVProxy, my mistake.
They directly connected the Pixhawk via the MicroUSB to their laptop computer, and ran QGroundControl on the laptop computer. They then used the graphical joystick on QGroundControl and clicked the arm throttle option. All thrusters spun except for one. To isolate the issue they connected that particular ESC to another thruster, and tried arming again, and it didn’t work that time either.

Thank you for telling us about the ardusub/mavproxy version issue. We are using ardusub 3.4, so arm check failure is to be expected then.

Here is a screenshot of QGroundControl:

Thank you for your assistance.


(Jacob) #4

Ok, that does sound like a problem with the ESC. There are some other things going on that are concerning me that I would like to work out first, before we settle on that conclusion. ‘Preflight’ in the QGC window indicates that it is not seeing the vehicle identifying itself as ArduSub. I see you have APSync running, that may be the cause. Is there any reason in particular that you are using APSync?


#5

Thanks for replying Jacob. We are using APSync because we were trying to have the Pi talk to the Pixhawk. The Pi and Pixhawk weren’t connecting when we tried to use QGroundControl and we thought that APSync would fix it, but it didn’t. At this point Ardusub is still installed on the Pixhawk.