Home        Store        Learn        Blog

BlueROV2 not arming

Installed QGC on a new laptop and now the vehicle won’t arm or disarm.

  • Lights and camera controls are working
  • Sensors and joystick are set up.
  • Can’t arm with the manual slider control in QGC or the Joystick control.
  • Video also isn’t working but I don’t think that’s related.

If you’re not able to arm but have a working MAVLink connection then I suggest having a look at the 'Arming Checks` section of the Safety page. Likely there’s a check there that’s enabled and failing.

That could be a check that doesn’t actually matter to your operation (e.g. GPS lock if you don’t have a GPS, in which case you should disable that check), or it could be something set up incorrectly (e.g. Board Voltage or Battery Level if the power sense module isn’t correctly configured in the Power page), or something else.

If it’s not an arming check issue, please specify

  • operating system
  • QGC version
  • ArduSub version
  • Companion version
  • if the same vehicle setup works with another topside setup, which operating system and QGC were used (if they’re different)

Our video troubleshooting steps may be relevant. If they don’t help, which operating system and QGC version are you using?

1 Like

The system was tested on a different topside setup - arming and disarming and the video feed worked.
It was connected back to the new topside setup and everything worked.

I’m not sure how it got fixed, but the problem has been resolved.

Thanks.

1 Like

Glad it’s solved at least :slight_smile:

Always frustrating to not know why something is working when it wasn’t previously, although perhaps in this case it just needed a reboot or something to reset some internal state (not sure whether that was something you’d tried in initial testing).