Home        Store        Docs        Blog

Assembled and powered on and... beeping


(Richard) #1

Hi All

I just got my BlueROV2 put together, batteries charged, and everything hooked up. I get video through to QGC, which seems like a good sign, but nothing else happens, just beeping from the ROV as shown in this video:

https://goo.gl/photos/vq4xLeYVf4MPRUeY7

Yes, I painted my fairings yellow, unoriginal I know but visibility is important. I suspect I’m missing some steps or pieces in the software setup. I’m using a Windows machine, the advanced electronics package, have a logitech F310 gamepad connected, latest build of QGC, and am pretty sure I assembled/connected everything as shown in the instructions, but obviously something’s a little off. I’ve done nothing to QGC, the Raspberry Pi or the SD card included with the kit.


(Rusty) #2

Hi Richard,

I’m guessing that the Pixhawk is not set up with the ArduSub firmware yet! You’ll have to upload the firmware using QGroundControl and set up a few parameters. There are instructions here: http://ardusub.com/initial-setup/#loading-firmware-on-pixhawk

You don’t have to do anything with the Raspberry Pi or SD card.

We’re working on making the instructions a little more clear in the transition from the physical building to the software setup. Let me know if you have any questions!

-Rusty


(Paul) #3

Have you set up a button to “arm” the BlueROV2? If so, what happens when you click on the button to arm the ROV? If you pick up the ROV and twist/turn it, do the compass and artificial horizon work properly?


(Mark Langille) #4

As Rusty noted, need to load Pixhawk firmware I suspect is the issue, we had the same.

 


(Richard) #5

Starting again today and things are as I left them yesterday-- no answer when I try to connect to the onboard Pi via SSH, and no video coming through to QGC anymore. Something seems to have happened when I got through to the Pi via SSH that one time… but I don’t see how, all that happened was I asked it to do something, it replied “no”, and that was that. Computer’s IP on ethernet is set to 192.168.2.2 as it was before. I have a spare SD card, maybe I should put a fresh install of the stock BlueROV2 setup on it and try that?


(Richard) #6

Typo in last post: computer’s IP actually set to 192.168.2.1. Tried from my Mac, same result. Interestingly, the Tx/Rx lights on the Pi and onboard Fathom-X tether board are green and blinky, while their link lights are both orange. Does that mean they have a 10mbps connection going? Tx/Rx light on topside Fathom-X board blinks only a little, link light (on the RJ45 jack itself) is not illuminated. When board powers up, PWR and LINK lights come on, LINK light goes out a few seconds later.


(Richard) #7

Gave the Pi a minty-fresh ArduSub/Raspbian SD card, still the same story-- no video, no answer via SSH.


(Richard) #8

Found the 9v battery powering my topside Fathom-X board is only putting out 7.5v with no load. Will replace battery and see if that helps.


(Richard) #9

Heh… yeah, it was the 9v battery.


(Mark Langille) #10

Did you flash the Pixhawk?


(Richard) #11

Doing better, but still no pixhawk flash. I’m using my Mac to talk to the Pi, and have internet sharing on, from my WiFi to the ethernet connection. When I run the git update command, I get a long delay, and finally this error message: “could not resolve host: github.com”. Internet access on the Mac is working fine. Why Pi no see internet?

I’ve tried copying over the .px4 file to the Pi and running the flash script manually, but it can’t seem to find the .px4 file. I put copies in the /home/pi/companion and /home/pi/companion/RPI2/Raspbian directories, still no success. Where is the script looking?

 


(Mark Langille) #12

I would just flash the Pixhawk via USB with QGC to know it is working.


(Richard) #13

Yeah, flashing with QGC may be only option. Tried the manual flash again, after realizing the path to the px4 file was local (on my Mac), not on the Pi. Script got underway but failed after awhile, unable to get things it wanted from the internet once again. Need ALOT more clarity on how to get the Pi able to see the internet.


(Richard) #14

Some success-- flashed pixhawk with QGC over USB. QGC gave me an error message (screenshot attached), but things seemed OK. Took a look at some of the vehicle settings options and then QGC crashed. Reassembled ROV, connected via tether, getting video stream into QGC but it does not see the vehicle. After a short time, find that video stream has dropped, LINK light on Fathom-X board is out, sure enough another 9v battery is dead. How much power does this board use? Anyway, the lights on the pixhawk were different this time, but ROV still sat there beeping. Going to the store to get a 12v power supply for the X board, will try again when I get back.



(Rusty) #15

Richard,

I think I can help with a few of these things.

First, for the internet access onboard the Pi, you can share that from your Mac, but you have to set it up first. You can do that by going to Sharing and click “Internet Sharing”. Choose “Wi-Fi” for the source and your Ethernet port or adapter for the destination. Then you should be able to update the companion repository remotely.

As far as flashing remotely, that feature is still somewhat in beta but requires the SD card to be updated in the first place with the most recent companion repository. Once you’ve got that the commands should work much more smoothly. The flash.py script can either take a local file (no internet connection needed) or by default it will download the most recent firmware file from online.

If you’d like to update without an internet connection, you can flash the newest ArduSub-Raspbian disk image file from here: http://ardusub.com/firmware/#images. We just updated that one today.

Thanks for the feedback - we’ll work on making the documentation more clear as far as internet sharing and setup goes.

-Rusty


(Rusty) #16

Richard,

You can use a USB connection to power the topside Fathom-X board if that’s more convenient. There’s a mini USB connector on there specifically for power.

-Rusty


(Mark Langille) #17

We use a USB power pack and works great.


(Mark Langille) #18

Rusty - Anything critical in the Pi update we should grab it for?


(Richard) #19

Ah, glad to find out about that USB connector on the fathom-x board.

No matter what I tried, never got internet sharing to work on either my Mac or Windows computers. The Mac was the easier case, but still never succeeded. I tried specifying subnet masks and router addresses, not specifying those things, reordering the priority of network connections, etc. Could talk to the Pi just fine, but Pi never got out to the internet.

Connected again now, strong video feed through to QGC but it does not recognize the vehicle. The beeping continues…


(Rusty) #20

Richard,

Okay. I’m not sure why the internet sharing isn’t working on your Mac. It’s tough to set up on Windows and Linux but usually works smoothly on Mac.

The beeping will stop once the Pixhawk is flashed! If you’re still having trouble with the flash.py script then please try a direct USB connection to get started.

-Rusty