Home        Store        Docs        Blog

Blue ROV 2 build


(West Coast Diving) #1

Hi

I am having fun building my new ROV and have to say its great quality.

I am having a few issues setting the software up. I have both the advanced package and standard, I am not having much joy with getting coms top side with the advanced so i have put it to one side for now and running the standard package as i need the ROV ready ASAP for a survey task i need to complete.

 

I very nearly have it up and running getting ,coms ,picture, and data and thruster control, however my lumens seem to come on very shortly after I connect the battery up. I have no control to turn on off and it is in the pixhawk rcin 7 slot? i am missing something? I have no control over the camera servo when using my xbox one controller,

The camera servo does tilt if i vert up and down it moves with those commands and centres again.

I am running on a windows 10 lap top

Any advice would be great, software is not my bag as you can tell!!

thanks Scott

WCD


(Rusty) #2

Hi Scott,

Thanks for the post! Can you share how things are configured on the “Lights” tab of the settings? That should look something like the attached screenshot. Also, a picture of how the plug is connected to the Pixhawk would be helpful as well!

Last, do you have the joystick buttons set up properly for the lights? Make sure they are set up for “lights1” instead of “lights2”.

-Rusty



(West Coast Diving) #3

Hi Rusty

 

Thanks for help yet again, my lights page is set up as per your screen shot and my controller is configured to “lights1” for dim up , dim down, and cycle still no joy as soon as i plug the single yellow wire in to pixhawk they are on.it is in the lower pin on the main input “rc in 7” as seen in my picture attached.

 

Many thanks

Scott



(Rusty) #4

Scott,

Okay. Thanks for the info. I have a few more questions:

  1. I see you mentioned that the camera tilt doesn’t work with the Xbox controller. But it does move when you move the vertical control joystick? Is that true? It should only move with button presses.

  2. Can you show a screenshot of your joystick button page?

  3. Last, we’ve got a “recommended settings” file that has all the parameters set as we have it on our ROVs. You can get that here (http://ardusub.com/firmware/#parameter-files). You can load that via the Tools menu at the top right corner of the Parameters tab. With that we’ll be sure that we’re on the same page as far as parameters go.

-Rusty


(West Coast Diving) #5

Hi Rusty

 

Thanks for getting back to me.

  1. yes the camera only moves when i use the vertical thrusters and i have no control via my xbox one controller.
  2. screen shot attached of my previous set up , now on the parameters on the link you sent me and still the same issue with the lights being on all the time unless i unplug the single yellow wire from pixlhawk.
Thanks Scott



(Rusty) #6

Hi Scott,

Thanks for the info and screenshot. With the new parameters, is the camera still moving with the vertical thrusters?

Also, can you tell me what firmware you uploaded to the vehicle? It sound like you might be using the firmware intended for use on ROVs with 8 thrusters, in which case that lights would remain on at half power and the camera would move with the vertical thrusters.

The proper firmware is here: http://firmware.ardusub.com/Sub/latest/PX4-vectored/ArduSub-v2.px4

You can reflash the firmware by connecting to QGC via USB on the Pixhawk. Let me know if that helps.

-Rusty


(West Coast Diving) #7

HI Rusty

 

That has worked a treat! lights and tilt are working, the thrusters are running on when i arm it now , i recon a controller cal will sort it, It will have to wait till morning as its 2am here and they are squealing a little, next door will not be to impressed ha ha. Thanks. I can start think about building the MCP back up and going for a vacuum test tomorrow providing the thrusters are ok. then a wet test !!! cant wait for a dive.

 

I must have used the wrong version of firmware? i did find it hard to tell what one i needed and did try a few.

 

Many Thanks

Scott


(West Coast Diving) #8

Hi

 

Still not had a chance to fully test the thrusters as my other half is night shift and they just spin up as soon as i arm the ROV. ( a tad lound)

 

On a side note, back to the advanced electronics package. I am having a go at getting it talking now, i know the standard is pretty much there so i have something to work with. I have plugged the HDMI of the rasberry Pi in to my TV the last line of data is saying…

—[end kernal panic - not syncing VPS:unable to mount root fs on unknown - block (179.2)

 

Any ideas? I followed the walk through changed my ip address and subnet mask and changed the fire wall settings to allow it.

 

Cheers Scott


(Rusty) #9

Scott,

Thanks for the update. Looks like the SD card image is corrupted, unfortunately. This is an error on our end when we flashed the card. There are two options:

  1. We can send you a new SD card immediately.

  2. You can reflash the image yourself by downloading the image here and using the flashing instructions here.

Let me know here or shoot me an email at rusty@bluerobotics.com. We want to get this resolved right away!

-Rusty


(West Coast Diving) #10

Hi

 

Last issue i hope, set back up on the standard package for just now. Have lights camera data tilt .

 

The vertical thrusters run as soon as i Arm the system and run. I have disconnected the controller and armed to system using the mouse and the same happens. i have done a calibration several times and i keep running the vert thrusters.

 

Any Ideas?

 

Thanks

Scott


(Rusty) #11

Scott,

I would guess that the RC3_TRIM is set incorrectly. This seems to be happening and we’re trying to track down the cause. It should be set to 1100 instead of 1500.

Let me know if that helps.

-Rusty


(West Coast Diving) #12

Hi Rusty

 

That’s done the trick, i should give you peace now for a while I hope :slight_smile:

 

All the best

 

Scott


(Rusty) #13

Great! For everyone else reading along, we are now shipping the Pixhawks with firmware and settings already in place so this shouldn’t be a recurring issue.

-Rusty


(West Coast Diving) #14

To be fair i am also hopeless with software, takes me a little while to get my head around what is supposed to be taking to what, but all in all the build is pretty straight forward and the product support has been second to none!!

Thanks again Rusty and the team!


(West Coast Diving) #15

Update, I did my wet test today and hit a issue with thruster direction problems. I have checked all my props are correctly set for cw and ccw. Check.

I have made sure all the thruster ESC’s are in the correct port in the pixlhawk and all the bulkheads are for the correct thruster in the correct position.

 

The Rov when given a vert up or down command wants to roll over on its side on both commands

when given an ahead/astern command it opposes the thrusters

The other commands work fine strafe left/right and heading turns fine?

Any Ideas?

 

Thanks Scott


(Rusty) #16

Hi Scott,

Make sure you follow the steps to set up the motor directions properly. This has to be done before using the ROV. See here: http://ardusub.com/initial-setup/#configuring-motor-directions

-Rusty


(West Coast Diving) #17

Hi Rusty

 

Sorry for the late reply, I have had a few wet tests now and had good success today as I got down to 15meters and did a mock boat mooring survey and found a outboard motor hood, Pictures and videos to follow.

 

Its very stable and nippy to fly having flown larger sea eye vehicles and work class this is a great wee sub :slight_smile:

 

The only issue I have is getting the auto functions to work. When stabilized mode is engaged the Rov heads back to the surface and with auto depth I can not control the depth and it slowly floats back to surface any ideas?

 

Thanks Scott


(Rusty) #18

Scott,

Glad it’s working pretty well! I’d love to see the videos.

As far as the remaining issues, I want to clarify a few things:

  1. When you enter stabilize mode, does it ascend rapidly or very gently?

  2. Does the depth sensor show the right depth when you are operating?

-Rusty


(Jacob) #19

Hello Scott,

Can you please upload a parameter file and a log file?

The parameter file can be obtained by connecting the pixhawk to QGC, clicking the Gears icon, and then selecting the ‘Parameters’ tab. There is an icon in the corner of the parameters tab that says ‘Tools’, from that menu, you can save your parameters to a file.

The log file can be obtained by connecting the pixhawk to QGC, clicking the ‘Widgets’ menu from the toolbar at the top of the window, and selecting ‘Log Download’. Click the ‘Refresh’ button to view the logs stored on the Pixhawk. Download the log from that window, and upload it here.

The logs are numbered in ascending order, and a new log is started when the pixhawk is armed for the first time after turning on, and ends when the pixhawk is powered off. If you are unsure of what log corresponds to the ‘flight’ when you experienced the issue, the size of the log gives an indication of how long the pixhawk was running after it started logging.

If you can, it would be helpful to upload a very short log, where you simply turn the ROV on, demonstrate the issue once or twice, and download the log. A video to go with this log would help, too. After the Pixhawk has been armed at least once, the highest numbered log in the Log Download window is the currently running log, if you click Refresh you should see the size increase.

-Jacob


(West Coast Diving) #20

Hi Jacob

I managed a dive this morning , However my video did not record(not sure what happened but the data was not on the usb stick?? will look in to that one! )The rain was hammering down and i had to pack up sharpish (joys of Scottish weather)

I will pull the log files off shortly and try and video it on deck just spinning up quickly and get those posted up here but i have attached the parameters bellow for just now.

Hi Rusty

  1. it ascends rapidly when in stabilised flight mode.
  2. The depths look about right hard to confirm as i was not on the boat only working of the jetty so no echo sounder. My partner was diving as you will see in the video to follow and she was only at 3m max it did not seem to read very much for the first 1-2 m
Many Thanks

Scott