Unable to Load Parameters for Heavy Retrofit

I’ve recently performed heavy retrofit on a pixhawk based BR2. I am having issues with the software part of the update. I’m following these instructions: https://bluerobotics.com/learn/bluerov2-heavy-configuration-retrofit-kit-installation/#software-setup

At Load Heavy Parameters step, Load Vehicle Default Parameters tab is not shown on the latest version of QGroundControl. Frame setup is only showing different configurations. The software is the BR version of QGC and it is downloaded through the link on software setup page. I have tried Windows, MacOS and Ubuntu versions on different computers and the tab is missing. Is this option moved somewhere else? I think these instructions may be out of date.

I can pick Vectored-6DOF but I know the channel assignments are wrong because turning on lights activate some thrusters (and the ROV is not armed).

I’ve tried downloading the parameter file for heavy version from this downloads page: https://docs.bluerobotics.com/downloads/

When I try to load this file using Parameters > Tools > Load from file; I get an error about missing parameters possibly due to a version mismatch.

Then I found this post and downloaded the “bluerov2-heavy-4_0_0.params” file from github:

When I load this file, QGC complains “There are no differences between the file loaded and the current settings on the Vehicle.” After a reset, channel assignments are still incorrect.

Did anyone encountered or fixed this issue? Am I missing something?

SW versions:
Companion Software Status Version 0.0.31
ArduSub Version: 4.1.0
QGC version v4.2.3

Hi @denis_b, welcome to the forum :slight_smile:

The option was removed because the “default firmware parameters” are specific to a single flight controller board, and we now support multiple flight controller types, so it was causing compatibility issues.

You should be able to load this file instead:
4.1.0-pixhawk-heavy.params (18.8 KB)

That does seem to be the case - apologies for the inconvenience here!

I brought this up and was told it’s already on our list of guides that need updating, so it should be fixed soon :slight_smile:

Hi Eliot,

Thank you for the explanation and the solution. I can confirm that these parameters can be loaded without any issue and they seem to work fine.

1 Like

Hi all,
I have installed the Heavy Configuration Retrofit Kit to my BlueROV2 and the new thrusters (7 & 8) do not work.
As directed in the guide, I have opened up QGroundControl followed by:

  1. Changed the frame configuration to “Vectored-6DOF” (note: the “load vehicle default parameters” followed by “Blue Robotics BlueROV2 Heavy” options do not appear)
  2. Rebooted the application and vehicle.
  3. In the motors tab, thrusters 1 - 8 appear. I began moving the sliders for the thrusters; thrusters 1 - 6 worked correctly, however thrusters 7 and 8 did not work at all when moving the slider back and forth.

Please advise on what to check/change/update?


Hi @HamishC,

I’ve moved your post here because it’s on the same topic. Please see the response above :slight_smile: