Home        Store        Docs        Blog

Ubuntu14.04 no video


(chengchang) #1

Hi , i am asking this question for my friend, he has a BR2 with a laptop (Ubuntu 14.04 LTS), and the video is not showing up for some reasons.

I had followed this topic: No Video in QGround Control Running Ubuntu 16.04LTS

So I have a BR2 with Ubuntu16.04 LTS, the same video issue happened to me and was solved by the topic above. Seems like (apt install gstreamer1.0-plugins-bad gstreamer1.0-libav) does not work on ubuntu 14.04.

I had coped the error code from my friends pc, please see below:
His BR2 is still assembling, only has pix+pi+usb camera+fathom board+battery something like that.

Thanks for the helps!

[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/QGCApplication.cc:259 - "Settings location "/home/prince/.config/QGroundControl.org/QGroundControl.ini" Is writable?: true"
[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/QGCLoggingCategory.cc:99 - "Filter rules "qt.network.ssl.warning=false\n*Log.debug=false\n""
[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/FactSystem/FactGroup.cc:88 - "No metadata for fact: "airSpeed""
[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/FactSystem/FactGroup.cc:88 - "No metadata for fact: "altitudeAMSL""
[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/Vehicle/MAVLinkLogManager.cc:359 - "MAVLink logs directory: "/home/prince/鏂囨。/QGroundControl/Logs""
[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/QtLocationPlugin/QGCMapEngine.cpp:215 - "Map Cache in: "/home/prince/.cache/QGCMapCache300" / "qgcMapCache.db""
[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/FactSystem/FactGroup.cc:88 - "No metadata for fact: "airSpeed""
[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/FactSystem/FactGroup.cc:88 - "No metadata for fact: "altitudeAMSL""
[D] at qrc:///qml/QGroundControl/ScreenTools/ScreenTools.qml:122 - "0.057291666666666664"
[D] at qrc:///qml/QGroundControl/FlightDisplay/GuidedActionsController.qml:129 - "_activeVehicle(0) _vehicleArmed(0) guidedModeSupported(0) _vehicleFlying(0) _vehicleInRTLMode(0) pauseVehicleSupported(0) _vehiclePaused(0) _flightMode()"
[D] at qrc:///qml/QGroundControl/FlightDisplay/GuidedActionsController.qml:129 - "_activeVehicle(0) _vehicleArmed(0) guidedModeSupported(0) _vehicleFlying(0) _vehicleInRTLMode(0) pauseVehicleSupported(0) _vehiclePaused(0) _flightMode()"
[D] at qrc:///qml/QGroundControl/FlightDisplay/GuidedActionsController.qml:154 - "_currentMissionIndex -1"
[D] at qrc:///qml/QGroundControl/Controls/SliderSwitch.qml:74 - "34.5 44"
[D] at qrc:///qml/QGroundControl/FlightDisplay/GuidedActionsController.qml:129 - "_activeVehicle(0) _vehicleArmed(0) guidedModeSupported(0) _vehicleFlying(0) _vehicleInRTLMode(0) pauseVehicleSupported(0) _vehiclePaused(0) _flightMode()"
[D] at qrc:///qml/QGroundControl/ScreenTools/ScreenTools.qml:94 - "ScreenTools: Screen.width: 1366 Screen.height: 768 Screen.pixelDensity: 4.417252538779154"
[D] at qrc:///qml/QGroundControl/ScreenTools/ScreenTools.qml:94 - "ScreenTools: Screen.width: 1366 Screen.height: 768 Screen.pixelDensity: 4.417252538779154"
[E] at /home/travis/build/bluerobotics/qgroundcontrol/src/FactSystem/FactGroup.cc:60 - "Unknown Fact "altimeter distance""
[E] at /home/travis/build/bluerobotics/qgroundcontrol/src/FactSystem/FactGroup.cc:60 - "Unknown Fact "altimeter distance""
[E] at qrc:///qml/QGroundControl/Controls/MainToolBar.qml:114 - "qrc:///qml/QGroundControl/Controls/MainToolBar.qml:114: TypeError: Cannot read property 'sub' of null"
[D] at qrc:///qml/QGroundControl/ScreenTools/ScreenTools.qml:94 - "ScreenTools: Screen.width: 1366 Screen.height: 768 Screen.pixelDensity: 4.417252538779154"
[D] at qrc:///qml/QGroundControl/ScreenTools/ScreenTools.qml:94 - "ScreenTools: Screen.width: 1366 Screen.height: 768 Screen.pixelDensity: 4.417252538779154"
[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/comm/MAVLinkProtocol.cc:413 - "Orphaned log file count 0"
[E] at :0 - "QQuickWidget: Attempted to render scene with no context"
[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/comm/MAVLinkProtocol.cc:381 - "Temp log "/tmp/FlightData179281.mavlink""
[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/FactSystem/FactGroup.cc:88 - "No metadata for fact: "airSpeed""
[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/FactSystem/FactGroup.cc:88 - "No metadata for fact: "altitudeAMSL""
[D] at qrc:///qml/QGroundControl/FlightDisplay/GuidedActionsController.qml:129 - "_activeVehicle(1) _vehicleArmed(0) guidedModeSupported(0) _vehicleFlying(0) _vehicleInRTLMode(0) pauseVehicleSupported(0) _vehiclePaused(0) _flightMode()"
[D] at qrc:///qml/QGroundControl/FlightDisplay/GuidedActionsController.qml:129 - "_activeVehicle(1) _vehicleArmed(0) guidedModeSupported(0) _vehicleFlying(0) _vehicleInRTLMode(0) pauseVehicleSupported(1) _vehiclePaused(0) _flightMode()"
[D] at qrc:///qml/QGroundControl/FlightDisplay/GuidedActionsController.qml:129 - "_activeVehicle(1) _vehicleArmed(0) guidedModeSupported(0) _vehicleFlying(0) _vehicleInRTLMode(0) pauseVehicleSupported(1) _vehiclePaused(0) _flightMode(Manual)"
[E] at /home/travis/build/bluerobotics/qgroundcontrol/src/FactSystem/FactGroup.cc:60 - "Unknown Fact "altimeter distance""
[D] at qrc:///qml/QGroundControl/FlightDisplay/GuidedActionsController.qml:154 - "_currentMissionIndex 0"
[D] at /home/travis/build/bluerobotics/qgroundcontrol/src/MissionManager/MissionManager.cc:859 - "inProgressChanged"
[E] at :0 - "QQuickWidget: Attempted to render scene with no context"
[E] at :0 - "QQuickWidget: Attempted to render scene with no context"
[E] at :0 - "QQuickWidget: Attempted to render scene with no context"
[E] at :0 - "QQuickWidget: Attempted to render scene with no context"
[E] at :0 - "QQuickWidget: Attempted to render scene with no context"
[E] at /home/travis/build/bluerobotics/qgroundcontrol/src/QtLocationPlugin/QGCTileCacheWorker.cpp:1065 - "No Internet Access"
[E] at /home/travis/build/bluerobotics/qgroundcontrol/src/QtLocationPlugin/QGCTileCacheWorker.cpp:1065 - "No Internet Access"
[D] at qrc:/qml/MavlinkSettings.qml:379 - "Rating: notset"
[D] at qrc:/qml/MavlinkSettings.qml:342 - "Wind: -1"

(chengchang) #2

i suggested him switch to ubuntu16.04 LTS


(haiyakeji) #3

会不会是视频流那里没设置好


(Patrick José Pereira) #4

Hi,

I was able to install the gstreamer packages without any problem in 14.04, try a sudo apt update before installing it. What kind of error apt is returning for you ?
I would also recommend to use the last LTS version 18.04 or 16.04, 14.04 is 4 years old !


(chengchang) #5

Thanks for the information.

sudo apt update , i will try that!

when i log into the companion computer, sometimes there is no information for the camera and camera setting was not available as well. SEE BELOW.

Also http://192.168.2.2:2770/vlc.sdp to access the stream on VLC, did not work. Also, i did not see any error messages related to gstreamer in the QGC console


(Patrick José Pereira) #6

Hi,

Can you go to http://192.168.2.2:8088 and run ls /dev/ | grep video, if you get no output from it, check your camera connection.


(chengchang) #7

Problem was solved, the USB camera has a bad connection cable.

Thanks for your help!