Home        Store        Docs        Blog

No Video in QGround Control Running Ubuntu 16.04LTS

(Michael) #1

I am having trouble getting video inside QGC while running on Ubuntu 16.04LTS. I can launch, from a terminal window, using gst-launch-1.0… and see video. I tried compiling and running the app image. I also tried running the Windows version through Wine, which didn’t work at all. I am new to software and found the software install directions for Ubuntu to be confusing at best.

My other problem seems I can’t scroll the windows down. The scroll bar doesn’t respond.


Ubuntu14.04 no video
(Rusty) #2

Hi Michael,

Thanks for the post. Did you compile QGC yourself or did you download from here?


(Michael) #3

Both, I tried both ways. Both have same results, no video in QGC. The
compile directions are not clear, to me, on what tools are needed for
Ubuntu 16.04LTS and exactly how to make the build.


(Jacob) #4

Instructions for installing video streaming dependencies are here.

There is some debate on whether these are accurate on Linux, please review (especially the last few comments) and provide feedback there if you can.

Also, click the purple ‘Q’ icon to get to the Application Settings page. Then click ‘Console’ and see if there is any output regarding video or gstreamer. You may also click ‘Set Logging’ here for specific debug options.


(Michael) #5

I did review the debate… I went through it and tried to follow the
suggestions. For those of us new to Ubuntu 16.04LTS and Linux, that thread
is not clear nor terribly helpful. I having the symptoms described, but no
luck getting the solutions to work. It reads as if solutions are to be
found, but I can’t decipher from the posts what the magic combination might

WRT the “purple ‘Q’ icon to get to the Application Settings page”. My
scroll bars are not working either.

(Brian Hopkinson) #6

I was able to get video on Ubuntu 16.04 following the instructions here:

the just of it is:
sudo apt install gstreamer1.0-plugins-bad gstreamer1.0-libav
(I then had to reboot Ubuntu 16.04 before the video stream was received).

(Jacob) #7

Thank you @brianh for clearing it up, you are correct in your directions. @ScubaRobot, I’m very sorry this got lost without a response for so long.

(wdodo) #8

I also met the similar program,hope to get the answer

(Jacob) #9

@MMMMK please try:

apt install gstreamer1.0-plugins-bad gstreamer1.0-libav