Home        Store        Learn        Blog

QGC Video Fail - Errors

I’m running a Ubuntu installation with the latest BR version of QGC and I can’t get any video. I’ve got control of the ROV and audio but no video. If I set a different IP or hostname to a different computer then that computer gets video fine so I’m thinking it is on the local side, not an ROV issue. In the console log of QGC I’m getting two error lines that just repeats over and over and over again.

[!] at /home/travis/build/bluerobotics/qgroundcontrol/src/VideoStreaming/VideoReceiver.cc:291 - "VideoReceiver::start() failed". Error with gst_element)factory_make('h264parse')"

[!] at /home/travis/build/bluerobotics/qgroundcontrol/src/VideoStreaming/VideoReceiver.cc:347 - "VideoReceiver::start() failed"

I’ve tried deleting and reinstalling. It’s worked before so I know it is possible. The only thing I can figure out that might have killed it is that I ran apt-get update and upgrade to update things and everything is up to date. I also installed mavproxy but I haven’t actually run it yet. It’s not crucial at the moment as I can sit here with my topside station and another laptop and I’m just testing in a pool so I can actually watch things easier than watching the camera but I need to get it figured out. Thanks!

There exists additional dependencies on linux:
https://github.com/mavlink/qgroundcontrol/tree/master/src/VideoStreaming#linux

Thanks Jacob. I never thought about dependencies because I thought I had had it working previously. I’ll go get those installed now and see how it works in the morning. Thanks!

:vulcan_salute:

1 Like

I now have the beautiful picture. Thanks for the assist!

1 Like

This really ought to be included on the VideoStreaming readme for the blueRobotics fork of QGC as well

Hello Justin,
We recently added a note pointing to the extra dependencies for linux in the setup instructions.
Are these not enough? What distribution of Linux are you running?

I’m running Ubuntu on a virtual machine.

Yes, I had followed those instructions. But I should note that that does’t point to what i’m talking about. I meant it should include extra commands to install gstreamer in the readme like it does at the base QGC repo here

However, now I realize that that wasn’t my issue anyways, so I’ll just mention what it was and how I fixed incase it helps anyone else.

The problem was when I went to build QGC I had issues because gstreamer wasn’t installed. So looking at your documentation here , I tried just using sudo apt-get install gstreamer1.0*; however, that doesn’t work because it tries to install gstreamer1.0-python3-dbg-plugin-loader and gstreamer1.0-python3-plugin-loader, which conflict. I should note, trying to build at this point still didn’t work. I would get an error with videoReciever.cc saying that it had no member for _startAudio() and a few other things.

To fix I had to uninstall gstreamer1.0-python3-plugin-loader and then install gstreamer1.0-python3-dbg-plugin-loader with apt-get. After doing that the build worked and I could run my own QGC.

TBH this may have been a bit a Ubuntu noob problem, but still maybe mentioning here will help someone else :slight_smile: