Home        Store        Docs        Blog

Cannont get video from the BlueROV2


#1

Hi,
I am a new user of the BlueROV2. When I connect the ROV with my computer(which is working on Ubuntu 16.04) and I open the QGroudControl, there are no video input from the BlueROV. When I check the console output, there are error message of “VideoReceiver::start() failed. Error with gst_element_factory_make(‘avdec_h264’)”. I have used the apt install gstreamer1.0-plugins-bad gstreamer1.0-libav command, however it is not working. When I connect the ROV with other computer working on windows and MacOS, everything works well. Can anyone suggest a way to trace the problem? And if everything failed, how can I restore QGround Control?


(Patrick José Pereira) #2

Hi,

Are you using QGC with AppImage ? Please, download the last version here.
QGC is a standalone application and no library installation should be necessary.


#4

I installed the QGC from the ardusub gitbook https://www.ardusub.com/getting-started/installation.html . The most confusing part is I am using dual boot for my computer and when I run QGC on the windows 10, it works fine. But when I work on Ubuntu 16.04, the video cannot be captured from the BlueROV.


(Willian Galvani) #5

Hello,

Can you run these commands and check if it helps?


#6

Thank you for all your help. I’ve tried to install gstreamer by all these commands

list=$(apt-cache --names-only search ^gstreamer1.0-* | awk '{ print $1 }' | grep -v gstreamer1.0-hybris)
sudo apt-get install $list
sudo apt-get install libgstreamer-plugins-base1.0-dev

However, the problem remains the same. The console keep reporting “VideoReceiver::start() failed. Error with gst_element_factory_make(‘avdec_h264’)”
I am wondering if this is the configuration problem for the Ubuntu? As I can control the ROV, I am quite sure that I have established a valid connection with the ROV but not for video streaming :frowning:


(Willian Galvani) #7

This specific issue affects video only. For some reason gstreamer is unable to create the h264 decoder node.

What is your current hardware? Do you have a dedicated GPU? If so, what drivers are you using for it?


(Jacob) #8
sudo apt install gstreamer1.0-libav gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad gstreamer1.0-plugins-ugly

#9

I have run gst-inspect-1.0 avdec_h264 on the terminal. It returns "No such element or plugin ‘avdec_h264’ ". I did a brief search on the internet but most of them suggested me to install the libraries which I have already installed. What will you suggest me to try next? Should I uninstall all the related gstreamer files and re-install them?


#10

@williangalvani @patrickelectric @jwalser Thank you for all your help. I have reinstall the whole system and with the libraries installed, it works! :smile:


(Willian Galvani) #11

I am glad you managed to get it working.
I tested in a Ubuntu 16.04 VM here and all it took was apt install gstreamer1.0-plugins-bad gstreamer1.0-libav.
Maybe something got corrupted in your install. If you see something like this again, I suggest reinstalling the packages above using the same command with the --reinstall flag.


(Willian Galvani) #12

I am glad you managed to get it working.
I tested in a Ubuntu 16.04 VM here and all it took was apt install gstreamer1.0-plugins-bad gstreamer1.0-libav.
Maybe something got corrupted in your install. If you see something like this again, I suggest reinstalling the packages above using the same command with the --reinstall flag.