Home        Store        Learn        Blog

Timed out trying to catch bootloader

Hey Everyone,

After some time off the water, I went back to use the ROV and tried connecting but was getting no telemetry.

I have:

  • Updated companion computer to 0.0.22

  • Tried updating Pixhawk firmware via 192.168.2.2:2770/system and it is saying ArduSub Version not found. I go to update stable version but, I get the message “Timed out trying to catch bootloader”.

  • I do see “PX4_FMU_v2.x (Pixhawk AutoPilot)” in the detected devices.

  • Then I tried connecting the pixhawk directly to a computer to update the firmware. This worked but I don’t see the same option as mentioned in this thread (ArduSub Updating Firmware through browser - no internet). So instead I select “ArduSub” “Nutx” “Sub” and then whatever firmware option that was provided. This work and I get telelemtry. However as soon as I plug the USB cable back into the Companion Computer nothing, no telemetry.

  • Turned everything on and off several times.

  • Tried different USB cables.

  • Formatted SD cards

It appears I can not get a connection between the companion computer and the Pixhawk? Any suggestions I am out of option!

Thanks in advance.

Hi,
Are you receiving video?
Have you checked your IP address? both the IP 192.168.2.1 and netmask 255.255.255.0 are very important.

hi,
try disconnect USB cable from ( Raspberry pi-Pixhawk USB cable ) pixhawk and reconnect at a point where firmware updation got stucked. The process is to load the bootloader by power recycling the Pixhawk.

-thank you

Hi Willian,

Yes I am receiving video and the IP address is correct.

Any other ideas?

Hi Sudheeshk,

Thanks, I am pretty sure I have tried this but I am a bit unsure how to power cycle the pixhawk? I have read a few people mention this?

Cheers
Joel

Ok, I have some progress…

  • I established that there was no mavproxy?
  • I re-flashed the raspberry pi SD card. This worked and I can now see mavproxy and I can establish a vehicle connection, i.e. video and telemetry.
  • However, ArduSub version is 3.5.4. Now, when I attempt to update, the ROV lights flash on, lots of beeps and repeated messages of “attempting to reboot on /dev/autopilot” followed by the “timed out trying to catch bootloader”

Any ideas?

Hi Joel,
i had the same issue. I can help you to solve this problem.
first you need to find your Pixhawk Bootloader version
connect pixhawk with your linux computer by using a USB cable, and run the following command on linux termianl.
ls /dev/serial/by-id/
you have to run this command with in 2-3 seconds after connecting your computer’s usb port. other wise the you will not get the bootloader information. so you need to open a terminal in advance and execute the commands immediately after connecting the pixhawk.
Kindly share the boot loader version.

Thans you

Thanks for your offer to help Sudheeshk.

I am running a windows computer and not sure what the windows command prompt version of your command is?

However, in QC Groundcontrol when I go to update the firmware via USB I can see it see connected to Bootloader V5 BoardID 255

I have also tried following these instruction:
https://docs.px4.io/v1.9.0/en/advanced_config/bootloader_update.html

How do you enable [SYS_BL_UPDATE] in the parameters if default is 0?

Ping!

So every time I try to update the Ardusub firmware the lights flash and the ROV beeps etc but it still comes up with “timed out trying to catch bootloader”.

I have tried following the github book on updating the bootloader but no success?

Could this be due to the pixhawk being older? Is it easier to replace the pixhawk?