Home        Store        Learn        Blog

ArduSub not found/ Pixhawk not connecting to Raspberry Pi

When I plug the pixhawk directly into the surface computer, it says that version 4 of the firmware is installed. When I plug it into the raspberry pi, the http://192.168.2.2:2770/system website says that the pixhawk is connected but ArduSub is not found. When I try to upload it, the console says “complete” but above it still says no ArduSub is found. QC ground control doesn’t work through the raspberry pi either. One time when I ran it, it said CRC failed but usually there are no errors.


Hi @eleni, welcome to the forum! :slight_smile:


The Pixhawk1-BL means that it’s detecting a Pixhawk bootloader rather than a valid ArduSub firmware, which means it needs to have a firmware flashed onto it. If it’s consistently not working to install ArduSub through the “Restore Default Firmware” or “Stable” update buttons in the “Pixhawk Firmware Update” section, then you can try directly connecting the Pixhawk to your topside computer via the USB cable (that currently connects it to the Raspberry Pi companion computer), and flash on the firmware through QGroundControl, as described here.

If there are further issues it’s likely worth going through our troubleshooting steps :slight_smile:

When I plug the pixhawk directly into the computer, it says that ardusub is installed.


It just says Pixhawk on the list of serial devices now but I’m not sure what specifically I did to fix that. However, the pixhawk and raspberry pi are still not connected and I have reset mavproxy using the http://192.168.2.2:2770/mavproxy site. However the “screen -r mavproxy” doesn’t produce the correct output.

Ok, maybe you just screen-shotted it after the update that didn’t work, instead of what it’s currently at :slight_smile:

Interesting. What output are you getting?
My guess would be that your companion software might not have all its components installed correctly, which is solvable by flashing the Raspberry Pi SD card with a pre-built companion image, but before trying that feel free to share the mavproxy output in case there’s something else going on :slight_smile:


This is what it says when I run the screen -r mavproxy command


The first time I run it, when the pi is first turned on, it produces these errors. However, pymavlink is installed at version 2.4.16

Hmm, definitely seems like there’s likely something going wrong there - it will likely be easiest to flash a new version rather than trying to determine what hasn’t been installed properly.

Those errors are for Python 3, but mavproxy on the current version of companion should run using Python 2 (which is also the Python pymavlink will be installed for). If you’re using a package like python-is-python3 that could perhaps cause an error like that, but if you’re not doing anything unusual then it seems like something has gone wrong with a dependency or how something is being called.

I’d recommend flashing a clean companion image, because at this stage it’s the most robust way to definitely end up with the right components installed and running together :slight_smile: