Home        Store        Learn        Blog

Throttle is not working in the Bluerov2/Vectored Frame

I’m using PX4 with Qgroundcontrol and I have some troubles with joystick. Firmware is ArduSub with Bluerov2 framework. When I test the motors numbered 5,6 they work perfectly fine by themselves but on the manual mode my vehicle doesn’t go up or down.

Also, even though I’ve done the calibration of the joystick, nothing changes with the sliders when I move two sticks on the general page of joystick setup.

I tried updating everything, I changed my joystick but nothing worked. I don’t have much time.
Any help would be appreciated.

Hi @zalex, welcome to the forum :slight_smile:

PX4 is an autopilot firmware - do you mean the Pixhawk 4? If so, we haven’t used or tested it extensively, but there are a few forum members who have used it and they haven’t reported an issue like this.

Since the motor test is working for the motors you’re expecting it to then the issue can’t be with the numbering.

  1. Have you armed the ROV (e.g. is movement in the horizontal directions working)?
  2. Are you sure the BlueROV2 frame is selected, and not another 6 motor configuration like the BlueROV1?

That’s unusual - are you sure the joystick you’re using is selected, and connected properly? Is the “Enable joystick input” checkbox ticked? Does pressing the joystick buttons cause the numbers on the right side to turn yellow?

This is what comes up for me with a PS5 controller connected via bluetooth, pressing down a button. Your ‘Active joystick’ name is likely different, but joystick movements and button presses should show up in the bottom two rectangles.

Sorry, yeah I am using Pixhawk 4.

  1. I have armed the vehicle and yes horizontal directions works but with delay.
  2. I am sure that BlueRov2 frame is selected.

I am sure I have enabled the joystick input and it responses, the numbers on the right side turn to yellow. But specifically the sliders doesn’t move.

The two motors just worked but I didn’t change anything. When I arm the vehicle and try to move it, motors work one by one with 5-10 seconds delays so, I waited for 35-40 seconds after arming the vehicle and now throttle is working. What causes these delays?

This sounds like it was running the motor detection routine. But it needs to be activated by clicking the button in the motors setup page.

We just arm the vehicle and move the stick full up and motors work with delays, we don’t use motors setup page.
Also when all the motors work at the same time we can control them but can’t stop them even we use the emergency stop.

Make sure you are running companion 0.0.28, and ardusub 4.0.3
What is your frame?
Is it a BlueROV2 or a custom build?
Is there anything non-standard? (power-over-thether or ping-sensors for example).

I am sure about the firmwares, I updated them a few times.
My frame is BlueRov2 not a custom build.
Actually, we don’t use lipo battery, we get our power from plug. We use regulators 220V to 12v for ESC’s and 12V to 5V for Raspberry and Pixhawk.

Are the thrusters doing a lot of noise? When they start they play some tunes. If they are playing these while in operation, it means they are resetting, with means your power supply is not able to handle them.

Keep in mind that they use regenerative braking, which means that when decelerating, they push power back to “charge” the battery, which many power supplies really don’t like.

They constantly “beep” when armed and the noises don’t stop till thrusters start to spin. We also have an error: “EKF2 IMU1 forced reset.” Are these two problems just about power?

constant beeping is bad. It means that either there’s no PWM getting to the ESC or that the pwm is not valid (not within 1500us ±25us).

The beeps are documented in the firmware manual.

The “EKF2 IMU1 forced reset.” is not related to ESCs, it usually happens when the ROV is sitting still and shouldn’t affect operation.

Sorry, I didn’t mean a constant beep, it is intermittent and too fast. And, I didn’t get the part: If there is no PWM how am i able to spin the motors after a while?

Hi @zalex,

Can you describe the beeping that occurs (e.g. short/long, every X seconds, low/mid/high pitch), and what you’re doing when it happens?

For normal startup our BasicESCs will do three short rising beeps on power up, to indicate the three phases of a motor are detected. It will then do one low longer beep once it detects a valid PWM input (between 1000-2000us pulse duration), and a high longer beep once it detects a valid ‘stop’ PWM input (1500us pulse duration).

_-‾ ___ ‾‾‾

If your ESCs aren’t doing that then you either have different ESCs or they’re being sent an invalid/unexpected input signal. Can you provide a bit more info about your setup? Is it Raspberry Pi 3B companion computer, 6 T200 thrusters, 6 BasicESCs, and just a different power supply + Pixhawk 4 instead of Pixhawk 1, or are there other differences from a standard BlueROV2 setup? Also, can you take a screenshot of the companion web interface System page confirming your companion and ArduSub versions? :slight_smile:

Thank you, beeps are short and approximatly every 0.5 seconds, mid pitch. And these happens after connecting the pixhawk to the ESCs, when they get signal I think? brushless motor beeping, (esc calibration) - YouTube our beeping is like 0:40 in this video, i didn’t calibrate ESC’s thinking QGC do that, do i need to do a calibration, if i have to how do i do that, it doesn’t show up in QGC’s power page anymore?

It is Raspberry Pİ 3B companion computer, 6 T200 thrusters, 6 80 A 2S-6S Hobbywing Skywalker ESCs, power supply from plug, Pixhawk 1 - I said Pixhawk 4, i was wrong. That’s all.

I am sorry, I couldn’t find companion 0.0.28 anywhere, we have 0.0.26 right now. Where can i find it?

We’ve only tested and documented operation with our BasicESC. Different ESCs are programmed differently, so have different expected behaviour (especially with respect to beeping, settings, and calibration). I found a Hobbywing Skywalker ESC datasheet from their website, which you can read to find out about the different beeping options.

Those ESCs seem to be made for drones, so I’m not sure if they’re bi-directional - they may only be able to drive the thrusters one way. If that’s the case you can either get different ESCs that support both directions (like our BasicESC), somehow reprogram the ESCs you’ve got, or make modify the ArduSub firmware for the Pixhawk to make it only run the thrusters in one direction (which would make controlling the ROV quite a bit less effective). Without a firmware and ESC type that are made to work together you won’t be able to meaningfully control your ROV.

There are companion installation instructions here, for either manually flashing the Raspberry Pi SD card, or updating from an existing companion image via our companion web interface.

We tried everything this sheet says but it didn’t work. We tried setting the throttle range but sounds are different. We don’t have a directly connected joystick so, we can’t do the calibration.

We tested the motors to spin two ways it works actually.

Not sure I’m able to do anything here/about this. It’s a set of ESCs that we don’t make or support, and I haven’t used them before so have little to no idea what they’re expected to do. Are you able to ask for help from where you bought them from perhaps? :slight_smile:

You might be able to pretend you have a joystick by using the motor test page, or by controlling the thrusters with a script, or perhaps using a thruster commander or servo tester or similar.

Interesting :slight_smile:
Although if you’re able to control the motors in both directions with your ESCs then I’m not sure what the problem is?