Software updates 15 April 2019

Tried it again today and it worked.

Got the ping working through the ROV as a result which is good :slight_smile:

Perfect @etienne, I was coming with the advice to power cycle the system and try again. What you experienced is apparently some sort of timing issue with the autopilot bootloader.

1 Like

I’m digging the new features! Everything is working fine for me, except I get a whole cascade of about 20 errors relating to GStreamer when QGC is loading. They look like this:
I just click OK and then QGC loads and everything seems to work fine. This is on Windows, of course. Still the same after a couple of reboots.

I think I have seen this before when changing QGC versions. Try uninstalling QGC and make sure no files are left, then install it again.

1 Like

Yup, uninstall/reintstall fixed it.


9 posts were merged into an existing topic: No companion update button available

To use v3.2.4-BlueRobotics-Rev6 and Waterlinked, what Companion version is working with that?

@Boko any companion version since the initial water linked support will work with 3.2.4-r6.

1 Like


Have tried doing the software update but and after a lot of tries, I’m still getting the ‘timeout trying to catch the bootloader’ problem as described above by Etienne- have tried the reinstalling QGC, to no avail.

I get a temporary solution - when I refresh the webpage it says Ardusub version 3.5.3 - and I then get control of the ROV etc, but when I restart again it’s lost. I’ve had no luck trying to upload the saved file either.




Hi Jacob,

I am running the heavy configuration setup with all the new updates.

A few questions about QGC:

  • Each time I open QGC it tells me there is a new version available but I got the latest version v3.5.0 how do I get rid of this nag?
  • Can I display the record button where it used to be?
  • Is there a button assignment to reset pitch and roll settings? (right now I press the toggle pitch/roll button twice)
  • Is there a way to display the pitch and roll settings?
  • Depth hold seems a bit agressive even in the tank. Is this normal?


same for me :slight_smile:

Thanks, I updated the instructions to uninstall first.

The Raspberry in our BlueROV2 does not recognize any wifi networks (wifi status: scanning). I don’t know why. Is there a way to do the updates through the tether?

I am only getting QGC GPU Compatability Mode or QGC GPU Safe Mode options not QGC. When I open it up in COmpatability Mode the camera doesn’t work, I just get a large red ArduSub logo…

Update: I was able to get it to work by reinstalling it and not moving the file from original install location.

Answering to myself. The wifi connection needs to be encrypted. If not encrypted the Raspberry does not recognize it. Now updating from the wpa2 encrypted connection from my phone…

Take a look at the installation folder. It is usually “C:/Program Files (x86)/QGroundControl”. Windows’ search is weird and sometimes does not show what you are looking for.

The Compatibility issue is known: Video in "Gpu Compatibility Mode" shows Firmware image Instead · Issue #7113 · mavlink/qgroundcontrol · GitHub

I just made an update following your tuto, and now I cannot connect to my BlueRov2: doesn’t work anymore. I can ping but only TCP port 22 is open.
What operation could I make to reinit the Rov connection?
I use Ubuntu.
Thanks for your help

7 posts were split to a new topic: Missing information in QGC instrument panel

Hi @bruno83,

Did you fix your problem ?

Hi @patrickelectric,
Not completly. I flashed the raspberry pi memory with the lastest version of it and now I can use the rov, but the port 2770 is not opened yet.
It is very strange!