Home        Store        Docs        Blog

Software Updates November 14 2017

(Jacob) #1

New updates are available for QGroundControl and ArduSub.


QGC has been updated to v3.2.4-BlueRobotics-Rev3. Changes include:

  • Add power draw to available values to display
  • Add date and time to available values to display
  • Add units option for displaying temperature in Centigrade of Farenheit
  • Add camera mount tilt speed adjustment slider to camera setup page (ArduSub 3.5.2+ only)
  • Various bugfixes and formatting/layout fixes

To update, download and install from one of the links below:


ArduSub has been updated to v3.5.2. Changes include:

  • Rework camera tilt input and slew rate limiting. This fixes mount stabilization.
  • Add joystick button functions for relays 3 and 4
  • Make it easier to completely disengage input hold
  • Announce input hold engaged/disengaged
  • Don’t announce tether turn status via audible messages
  • Allow adjusting PWM output range for lights channels
  • Always neutralize control inputs during pilot input failsafe
  • Various bugfixes

Note, after updating to 3.5.2 on a BlueROV2, make sure the ‘Servo Reverse’ setting is selected on the Camera setup page.

To update:

Test dive no controls
(Svein H.) #2

I just tried to update my pixhawk, what to do now? I have tried to onplug the USB to the Fathom-x… but there is no response after this message

(Jacob) #3

Ok, this means to disconnect the usb cable from the autopilot inside of the ROV, not the Fathom X. I should change the message.

You can ignore the unplug USB message, it should not actually be necessary. Just wait, and if the update fails or succeeds it will say so. Please unplug-replug the battery from your ROV and try again.

(Svein H.) #4

Started first with updating QGC and then pixhawk, seems to work just fine now. Really like to have the time/date in the overlay, nice :slight_smile:

(Svein H.) #5

I have updated the New version on two Laptops, but on the Third i got another widgets in the setup menu. Start on top With Air speed, Altitude, Altitude-rel, Climb rate.
what cause this? i have been testing all Three Laptops With the earlier Version of QGC and they was all Equal before i updated them.

(Jacob) #6

You need to connect the computer to an ROV at least one time, then it will know that you are using it with a submersible vehicle instead of an aerial vehicle.


why is the camera tilt reversed after the update?

(Jacob) #8

Aha, I forgot about this bit. This update did some work on how the camera is tilted which changed the behavior in a few ways. Now, instead of tilting in steps, the tilt continues at a constant speed only for as long as the button is pushed down. The speed can be adjusted on the Camera setup page. This work also fixed a bug hampering the performance of camera tilt stabilization. Finally, there was also a long-standing sign error (the servo direction has been flipped this whole time, actually).

For the BlueROV2, you will need to check the ‘reversed’ box on the Camera setup page, or load the BlueROV2 default settings from the Frame setup page.

(Jacob) #9

(Maurizio) #10

Unfortunately I cannot fint joystick btn functions for relays 3 and 4…
Running QGC v3.2.4-BR-R3 and ArduSub 3.5.2 (also tryed 3.6-dev and directly compiled from github). BRD_PWM_COUNT is set to 2 PWMs, giving relay 3 and 4 AUX PIN 3 and 4. Joystick is an Xbox (XInput Controller)

What am I missing? Is there something I have to do to enable relay 3 and 4?

Thanky you :slight_smile:

(Jacob) #11

Hi @mau792,

I forgot to update the parameter metadata in QGC so that it would be aware of of the new options on the autopilot side. You can set up relay functions 3 and 4 from the Parameters tab in the Vehicle Setup menu. Edit the JS_* parameters, and (manually, advanced) assign the parameter value. These are the values corresponding to the relay 3 and 4 functions:

    relay_3_on            = 57,           ///< trigger relay on
    relay_3_off           = 58,           ///< trigger relay off
    relay_3_toggle        = 59,           ///< trigger relay toggle
    relay_4_on            = 101,           ///< trigger relay on
    relay_4_off           = 102,           ///< trigger relay off
    relay_4_toggle        = 103,           ///< trigger relay toggle

(Maurizio) #12

Hi Jacob, thank you for your answer. I’ll try tomorrow, sure it’s gonna work.

btw, you’re doing a great job here with ardusub :slight_smile:

(Svein H.) #13

Can you please explain what kind of functions relay 3 and 4 is ment to controll and what we potentially can use it for? Looking into adding a extra servo and would be happy for some help with connecting it to the pixhawk.

(Jacob) #14

There are button functions to control relays and servos. The relay functions will toggle a pin on the Pixhawk between 0v and 3.3v, so you can switch things like relays and mosfets. You can configure up to 4 individual pins for relays. The servo functions will output pulses, and you can increase/decrease the pulse width by pushing buttons.

(Svein H.) #15