Home        Store        Docs        Blog

No companion update button available

There’s a few considerations:

  • preparing the sideload file is a bit of a time consuming task.
  • there are very few (<10) people who have actually needed/requested/used this method to update
  • because of this it is best (for us) to let a stable release stabilize a bit before preparing the sideload file. We have already prepared another update (0.0.17) to release soon.

I’ve also removed the file from the link you provided. As you pointed out, it’s old.

Ah, I understand. I have since fixed the problem by using my cell phone as a local hotspot for a better / different wifi connection. The Update button magically appeared when I did that, and I updated successfully.

1 Like

I also do not see the Update button in the state of 0.0.15.
The latest Ardusub 3.5.4 has been successfully updated.
Suspected router or network problems. We have made connections to different networks and locations of mobile phones. But that button is not displayed. Is there any better way to solve this problem?

@denden , does your ROV have a green “CONNECTED” indication under the internet status on the network setup page? You must first connect the ROV to the internet.

When you have the internet connection, please check the system page and refresh to see the update availability.

Yes, of course there is a connection to the internet.

Hi,

I am on the v0.0.16, no udpate button for version 17, is it normal?

Hi @Stevenlb, have you connected the ROV to the internet on the network page?

Yes, I did the Ardusub software update but after that and reboot the companion version is still 0.0.16.

I will check again tomorrow.

Hi Steven,

Did you refresh the browser page?

I made the same mistake wondering what was going on and ended up flashing it 3 times for no reason :slight_smile:

Hi,

Yes I did. I tried several times, I am still stuck on PI V16…

I have got a problem with the underwater GPS as I do not get the depth reading from the ROV. Can it be linked to the fact that the PI did not update?

I have an inspection to do for a client ASAP, let me know please.

Hi Steven, it is not clear what your problem is.
Can you please provide a screenshot of the network page in the companion web interface?
Please also include some screenshots of the system page.

Yes:

To begin using the Water Linked system again and get through your ASAP situation, you may also revert to using our previous edition of QGC (3.2.4-r6) here: https://github.com/bluerobotics/qgroundcontrol/releases/tag/v3.2.4-BlueRobotics-Rev6

Hi Jacob,

Below are some pictures:

I already tried to go back to the previous QGC version, it did not work when I was on site.

Hi Steven,

Try and connect the Raspberry Pi directly to your computer with a network cable to eliminate any communication issues when updating.

Cheers,
E.

I also can not flash companion frame through Internet,can you give me the link which I can download and flash to SD card

@Stevenlb @MMMMK, please try the suggestions here about refreshing the page, and downloading a system log to help us debug and resolve the issue: https://github.com/bluerobotics/companion/issues/251

webui.log (789.8 KB)
Hi Jacob,

Thanks for your reply, above is the log from the last time I tried to update the companion. Let me know.

I have the same issue, have internet coms, but no options to update. My last version is 15.

Hi Jacob,

Let me know tomorrow if you have time to have a look and what to do in order to realize the update. I have a waterlinked inspection on thursday so I need to be ready!

Hi @Stevenlb, I’ve found the problem in your log:

2019-04-24T12:49:38+0000 <log> index.js:776 () ping -c1 google.com :  Error: Command failed: /bin/sh -c ping -c1 google.com
ping: unknown host google.com

Based on this entry in the log, I would expect the ‘internet status’ on the network page to indicate ‘disconnected’. Can you confirm this?

@SHS Please provide a log as I instructed @Stevenlb.