Home        Store        Docs        Blog

No companion update button available


(Dietmar Pichler) #1

Hi,
i just turned on my BlueROV2 to perform the mentioned update - but there is no “Update companion” button :frowning:

Any idea what could be wrong? or can i download the update file somewhere? it still shows 0.0.15

thx

Didi


Software Update - Companion - December 2018
(Dietmar Pichler) #2

Did you See the update Button? I Hope i can Update without disassembling the Wohle rov to be alle to get the so card :frowning:


(Jacob) #3

Hello @Dpichler, Does the network page show that you have an internet connection? Please make sure you have connected the ROV to a wifi network on that page.


(Dietmar Pichler) #4

Hi, of course- i can update the pixhawk from there with no issues. but i do not have the button to update the Companion part at all.

any possibility to update via network without disassembling the ROV?

like Download image and upload from there? i have this option …

Didi


(Jacob) #5

If you have an internet connection, the update button should be available.

There is no way for a network update at this time without this button.

Have you made any modification to the ROV software or entered any commands on the raspberry pi console?


(Dietmar Pichler) #6

Hi,
internet connection is OK - shows connected to the WIFI (which is a mobile hotspot on my iPhone) and the test shows okay.

i’m not wer of any modification - everything else is working as expected. i’m currently on a business trip - so i cannot turn on my ROV and check. but could we do remote session when i’m back home?

Didi


(Jacob) #7

Yes, This sounds strange. Please contact support@bluerobotics.com when you are ready and we can hang out.


(Bo Koppel) #8

Hi!
I have same issue, no update button in 0.0.15
I have internet indication in network page, tried both by wifi and like earlier upgrades, by ethernet/router.
Will not work with ROV for some week, so not urgent.

I have a distant memory of having similar issue like a year ago, that time it was something regional, ie based in europe that update servers did not like.

Bo


(Kevin) #9

@Dpichler and @Boko We have had some of our engineering ROVs update just fine and we have had at least one not see the update either. It was on a different Wi-fi network, which was a bit slower than the one we have at our facility, so that may have something to do with it.

For the one troublesome ROV we had, I removed the SD card, erased it with SDformatter and then flashed the 0.0.16 image directly from here: Installation-Raspberry Pi


(Bo Koppel) #10

FYI
Now tested with a 1 Gbit internet fiber connection.
Still no update button, not with ethernet, nor with Wifi.
So, internet speed seems not to be the case.


(Dietmar Pichler) #11

Holy … Whats the best Method to get the so Card oft of this piece of Technology - Looks as you have to disassembe „everything“ behause its next to the Front of the Frame where the Camera is mounted …

Just Wanderung if there are Any Tipps how to get it out quickly?

There is an Upload Option on the System Page in the Companion section where i can browse for a zip file and Upload it - whats this for? Would it also work using this?

update:
found the “easy” way - just remove the front and oull out the sd Card :wink:

Cheers


(Jacob) #12

@Bo @Dpichler, This may be a problem with your router configuration, not allowing the ROV access to the internet. If you continue to have trouble, you may post the log stored at /home/pi/.webui.log.

As @Dpichler has pointed out, you may always update by directly writing the companion image on the sd card.


(Bo Koppel) #13

webui.txt (429.2 KB)

Hi @jwalser!
Thanks for good advice as always on error checking!

I have tried several wifi and ethernet connections to get the Companion update button visible.
Also tried wifi and ethernet connections combined.
Attached is webui.log, renamed to webui.txt
(BTW I was not allowed to upload extensions .log to the forum)

Bo