Home        Store        Docs        Blog

No Internet when on Wifi for Update


(Drew Fulton) #1

So I was preparing to do the heavy build this afternoon and realized that I hadn’t checked the software version of the companion. After a quick check I was running 0.10! I was able to connect to my local wifi but I could never get an internet connection. I have now flashed the update which worked fine so I’m now running the latest but I’d like to check the pixhawk firmware and I still can’t connect to the internet over wifi. I’ve tried multiple networks. Any ideas?

In the meantime, since I’ve got the whole thing taken apart to get access to the SD card, I’m just going to connect the pixhawk to my laptop via usb and update through QGC but thought I’d check here for future reference. MY goal is to open this enclosure as rarely as possible!

Thanks!


(Jacob) #2

It sounds like your router is denying the Pi internet access. Please consult the router documentation and verify the settings. It is possible to do the update through the tether without internet access on the ROV. Contact me if this is required.


(Drew Fulton) #3

That makes sense. Strange since I have a whole bunch of other raspberry pi’s on the network without a problem. In the meantime I got all the software updated so I should be good to go for now. I’ll mess with it more tonight cause I’d like to install some stuff through pip and apt-get. Guess I could pull the card, drop it in another pi and do all I need and then drop it back into the ROV’s Pi but that seems excessive. I’ll work with the router for now.

Thanks!


(Jacob) #4

If that works, I would be surprised. Please let me know. There is also a log at ~/.webui.log. If you visit the network setup page, that stuff will show up near the end of the log, then you can send it to support@bluerobotics.com.