Accessing BlueOS and connecting to Wi-Fi

Hi there,

We’re trying to run a software update on our ROV, which hasn’t been used for 6-months, but are running into a couple of problems accessing BlueOS.

At the moment we cannot seem to access the BlueOS web interface. Neither or blueos.local (from BlueROV2 Software, Computer, and Joystick Setup Instructions ( will respond. We’re getting an error message saying that the page cannot be reached. We are fully connected to the internet via Wi-Fi.

We did manage to get the BlueOS web interface to load about an hour ago, which, as above, it will not do now. However, we were unable to connect to our Wi-Fi network via the interface. It would not show as an option despite it being a strong network connection. It just won’t show up at all.

If anyone has any advice on either issue, it would be much appreciated.


Just to update we’ve tried connecting via an ethernet cable, and have now been able to access the BlueOS interface. However, we still cannot see our Wi-Fi as an option to connect to.

When we go to tools, and version chooser, the following error message is coming up: <error fetching on line tags-cannot connect to host ssl-default (temporary failure in name resolution>. It does say that our software is up to date in the same page…but we’re not sure if this is the case, or if we cannot connect to see available updates.

Firmware is also not showing as having any necessary updates (the latest stable release).


Hi @YWT,

If the Raspberry Pi does not have an internet connection then it will understandably fail to connect to the online servers where additional BlueOS and Ardupilot firmware versions are stored. The “failure in name resolution” error message is something we should likely intercept and replace with something that’s easier to understand, but as I understand it that’s just saying BlueOS can’t connect to DockerHub to try to fetch additional versions.

My main thoughts here are that either

  1. the device is in some sort of Faraday cage that’s preventing access to the wifi
    • e.g. if it’s in a metal enclosure, or
  2. it’s incapable of accessing the frequency band your wifi is on
    • e.g. the Raspberry Pi 3B is only capable of accessing 2.4GHz wifi networks (not 5GHz ones), and
    • for the Raspberry Pi 4B you might need to use the raspi-config tool to change the wifi locale to your country if it’s been set to one that doesn’t support the network you’re trying to use

Another option that may be worth trying is internet passthrough (via the tether), which requires a bit of extra setup at the topside but means you may not need to connect to the wifi at all.