Home        Store        Docs        Blog

Shift button non-functional


(TCIII) #1

Hi All,
I am presently using ArduSub rc3 and the daily QGC daily build from this last Tue on a Windows 10 laptop and I have found that neither the Xbox 360 Silver X or the Logictech F-310 Logitech Logo pushbutton switches being used for the Shift button are showing up in the QGC Joystick Calibration page as button #5. Both the Xbox 360 Silver X or the Logitech F310 Logitech Logo pushbuttons are recognized by Windows 10 as they cause Windows 10 to display a game request dialogue box, but neither are visible in the Windows 10 joy.cpl application. Has anyone experienced the same issue with QGC on Windows 10?


(Bryan) #2

I am using a Logitech F-310 and had the same problem.

If I remember correctly these are the steps I took to fix it:

  1. Ensure the switch on the underside of the F-310 is in ‘X’ mode.
  2. Start QGC.
  3. Press the logo/shift button.
  4. The Windows Game Bar prompt will ask if this application is a game or not. Select “Yes.”
  5. Select settings on Game bar and uncheck “Open Game Bar using (Xbox logo) on a controller”
  6. Uncheck “Remember this as a game”
  7. Restart QGC.

(TCIII) #3

@coastwatchalliance,
Thanks for the hint, much appreciated.
I will give it a try.
Regards,
TCIII AVD


(Dietmar Pichler) #4

Hi,

Looks as I have the same „problem“. We had the first dive yesterday. Everything went good with some minor hickups like motor directions and so.

Because I’m in Europe I use mode 2 like on my aerial drones. Having my controller f310 in x mode did not work - yaw and throttle was on buttons and I found not how to change this. Changing the controller to d mode fixed at least this issue - but shift button not working :-/

Not a big issue at a first test dive … will work an this today’s …


(Rusty) #5

Hi Dietmar,

Please try the “Mode” button on the F310. That button switches the joystick and the D-pad buttons. It’s easy to hit accidentally and switch them.

-Rusty


(Dietmar Pichler) #6

Hi,
i re-did the controller configuration and it looks as everything is working now.
maybe i hit the mode button by accident - i’ll keep this in mind for further dive. its an amazing piece of technology :wink:

thx & best regards

Didi