Shift function LOGITECH F310 on MAC Not working

Good morning.
I think I read all topics concerning the LOGITECH F310 but most of them are concerning help on windows,
My problem problem is the shift button on the controller don’t want to work.
I tried “D” mode not working
I tried “X” mode, the controller don’t work with QGC in this mode.
I tried to map, the “shift” function to another button, but this also not work.
Thanks for your help and support.

Hi @Gilles, welcome to the forum :slight_smile:

Could you please clarify what you mean by “the shift button on the controller don’t want to work”?

  1. Is it the functionality that’s not working as you expect, or is the button not registering as being pressed?
  2. When you’re in the QGC joystick button mapping page, does the number for the button you’re trying to assign turn yellow when you press the button on the joystick?

Hello thanks for your reply Eliot.
I will precise:
1- I believe the shift button is working properly, the joystick is new from last week.
2- In the QGC mapping tab, when pressing the shift button this one (by default n° 5) should appear yellow. Result not appearing yellow.
When I try to assign another button for the shift function lets say for example “A” button this one also not mapping.
All other button fro the joystick are working appearing yellow.
thanks for your help