Home        Store        Docs        Blog

QGC does not recognize my joystick anymore


(Heinz) #1

Has anyone had this issue? I’ve been using the ROV for a while and now all of the sudden QGC does not recognize the joystick. I tried plugging the joystick to other usb ports and it still wont recognize it in QGC. Im using a logitec and the logitec software recognizes the joystick and all the buttons but QGC does not. Any advice would be greatly appreciated.

Heinz


(Chris) #2

Are you using an Logitech F710 by chance? I had some recognition issues with one of those, and figured that I have to change the mode to direct input for QGC to recognize it.


(Heinz) #3

Chris, yes thats exactly the joystick Im using. The entire computer recognizes the joystick but QGC quit recognizing it. Would you mind telling me where you would change the the mode to direct input?

Thanks

Heinz


(Jacob) #4

There is a switch on the back of the joystick, I believe the ‘X’ position is direct input.


(Heinz) #5

I wish it were that easy. If that’s the switch then I already went through that a while back. I have verified that and its always been in that mode. I have also tried to move the joystick to other free usb ports. I’m going to try a completely new install of QGC and the associated software in case something got corrupt.

Thanks


(Chris) #6

That controller caused me quite a headache aswell… The procedure I have to go through to get it working is as follows:

  1. I go to “setup usb game controllers” on the control panel
  2. Check if the controller is listed as Controler Wireless Gamepad F710
  3. Go to Properties and check if the controller works properly. (If it doesn’t do anything, try pressing the mode button, and then check again)
  4. Only after that I can start QGC and the Controller is properly recognized.

Maybe this helps :wink:


(Heinz) #7

Chris,
thanks for the advice and I tried it but it didnt work. I worked on QGC for hours until it finally started to recognized the Xbox wired controller. I tried so many different tricks to get QGC to work with the logitec but it never worked. I had tried both controllers a few weeks ago to see which one I liked better and Im guessing when I tried the Xbox it must have changed the registry somehow. Im not a computer programmer nor do I have the time and patience to fix it. Im just glad I got a controller to work with QGC even though it wasnt the one I wanted to use.
Heinz


(Heinz) #8

Update:
I decided not to give up on the Logitec controller and did get it to work!

SInce the Xbox wired controller did work with QGC and the Logitec who has been working since day one but in Direct mode and stopped working shortly after I experimented with the Xbox controller I thought I’d try something and it worked.

For some reason when you switch the Logitec controller from direct mode to X mode QGC will recognize it. You have to have the controller in X mode before you start QGC or it will not work. In QGC in the joystick adjustments the drop down menu does not say “Logitec controller” but instead it says “XYcontroller”. Unfortunately the Logitec Game Profiler does no longer function in X mode but at least it works and runs everything ok.
I hope this helps someone from two days of frustration trying to figure out what happened.

Heinz