Home        Store        Learn        Blog

Problem with QGC (video stream and gamepad)

it’s quite a story. I have a gray screen regularly when I start video recording by video stream. I was advised to switch to a QGC version above 4.0.5. this solves the problem of gray screens but impossible to calibrate the joystick. If I get there and the sliders are in the middle of the general joystick tab, the joystick doesn’t respond at all. impossible even to arm the ROV. I went back to version 4.0.5 of QGC, I again have gray screens in video stream and my joystick no longer responds in this version. I am a little lost.

Hi @Bruno1 , when on version 4.0.5, check to see if “enable joystick” is ticked in the joystick menu, also that “TX mode” is set to 3. you may have to fully calibrate the joystick once enabled. If on windows 10 you may also have to enable joypad in X-box game bar menu, (and tell it QGC is a game if you want to record and have the GPU for it) hope this helps in some way.

hello, thanks for the note. but that does not change anything, either the joystick cursors are anyhow or they are in the center but the joystick does not respond, no key even on “enable” or “not mapped”.

Hi @Bruno1,

Could you provide some more information on the type of joystick you’re using, and how it’s connected? If you’re on a Windows computer you should be able to use QGC 4.1.4.

It would be helpful if you could share some screenshots and/or additional details on what you’re seeing.

  • Is the joystick being detected by QGroundControl?
  • Are button presses shown?
  • You mentioned calibrating - does that mean you were able to run the joystick calibration process successfully? Do you have a red joystick icon (not connected/needs to be calibrated) or a white one (calibration complete)?
  • Is the joystick being detected by QGroundControl?
    → YES (pict 1)

  • Are button presses shown?
    → no when the cursor is in the middle (see capture) no key responds. the logo is in white (pict 1)

  • You mentioned calibrating - does that mean you were able to run the joystick calibration process successfully? Do you have a red joystick icon (not connected/needs to be calibrated) or a white one (calibration complete)? (pict3)

→ I am not able to calibrate because the tool hangs (capt 3)
no response from the joystick or no communication with the software (pict3)

1-


2-
3-

White icon means it’s connected to a joystick that it’s already been calibrated for. If the joystick was working earlier and now is no longer working with the same application and same settings then perhaps there’s something wrong with the joystick, or you might need to restart your computer (in case two applications are fighting over the same joystick or something).

In your second picture it looks like you successfully got both of the joysticks to be recognised. Is that correct, or was the display stuck showing full left lateral and left yaw turn, and full forward and upward?

I would suggest you try restarting your computer, and seeing if that restores the functionality. If that doesn’t help then perhaps try @murf’s suggestion:

@murf’ write about Xbox game bar. I have logitech f310…

I asked previously which joystick you were using and you didn’t respond.

For the Logitech F310 make sure the switch on the back is set to “X”.

If that and restarting your computer don’t help let me know and I’ll ask internally if someone has experienced an issue like this before :slight_smile:

Sorry,
my joystick is F310 and on “X”
with restart computer it’s the same.

Is there any other joystick option on the #2 image “Active Joystick” combobox ?

Hi @patrickelectric . no not other option. may be it’s problem with windows 10 ?

I had this exact issue initially when upgrading to QGC 4.1.4 and also using a Logitech gamepad on W10. My fix was getting a fresh calibration. Make sure the mode button isn’t enabled as that changes control mappings and I’d expect could add complexity to finding a solution for you.

ETA: I’ve found the dongle unplug/plug in technique to be a useful workaround for many joystick connectivity issues as well

I tried all the ways to calibrate, by checking or not the “enable” box with the “X” in position. as soon as I start to calibrate, there is a blockage on the right lever at the bottom (the 2nd command). if I look on the general tab I have “not mapped” which is normal but I cannot go further

Strangely enough, I tried with my old PC win 10 QGC 4.0.5 PC and everything works straight away. whether it is the gamepad and the video. With the new hardened PC which is more powerful (i5 11th Gen - 16Go Ram - Geforce 1050) I had to install QGC 4.1.4 to avoid having a gray screen in video stream and the F310 gamepad does not work on any of the versions QGC.

4.0 has some issues with not using hardware decoding on more powerful windows devices, which is why the video works well for some but not others. 4.1 allows forcing hardware decoding, which means it should work well if the device is capable of working well.

The fact that your joystick is working fine on a different computer makes it seem like perhaps your current one has some kind of driver issue or something. I’m not sure why that would be the case (especially since I believe you mentioned that the joystick was working at the start, before you first updated QGC).

To make sure that QGC is actually detecting the joystick properly, does the joystick icon go red again if you unplug the joystick? It may also be worth using a joystick web tester to see if the joystick is working as expected on the computer.

Given restarting didn’t help, it might be worth trying to reinstall QGC, or possibly even reinstall Windows (I really don’t think that should be necessary, but it might work). It may be slightly less work to set up WSL and install QGC on linux and see if that works, but once again it really shouldn’t be necessary to do :confused:

You mentioned privately that you’re waiting on a different controller type to try, which will hopefully work out of the box (like your current F310 is expected to).

One of our engineers has brought up that it

Hope that’s helpful! :slight_smile:

i will try to uninstall all logitech drivers, but before reinstalling directx i will try with an xbox controller. If that solves the problem I will be sure to let you know.
I don’t know if I am on the Windows Beta probgram, how do I know? the PC is new arrived with this version of windows 10 Pro

apartment the joystick works correctly because the tool on windows is correct to test the joysticks. And it’s ok on gamepad-tester.com with Dual mode and X mode. I will wait to receive the xbox controller before redoing the installation of the operating system.
with dxdiag on windows, I see - version Directx : Directx 12 ( same as old PC)
associated device : Controller (GamepadF310)

Ok great, hopefully that works! :slight_smile:

I just looked it up and it seems like it requires signing up for, and isn’t really something you could accidentally be on, so it’s unlikely you’re on it. If you want to make absolutely certain, there’s some information here about how to check if you’re on it.

This does seem like the joystick itself and the relevant drivers seem to be working. Maybe try uninstalling QGC and deleting the QGroundControl folder from your Documents to try to make sure it doesn’t remember any saved/broken settings, and then try reinstalling it?

Feel free to try the x-box controller first though :slight_smile:

Hi Patrick,
I just installed linux 20.04.3 with QGC 4.0.5 because I was having problems with win10. I have no video feedback on the screen. but i don’t know linux well. can be codecs to install?
Thank you