QGC 4.0.5 on Mac, joystick not working

Hi there,

I’m trying to use a F710 Logitech joystick to control the BlueROV2 in QGC.
The version of QGC i’m currently using is the 4.0.5, since the later versions don’t work on Mac (no video).
My Mac recognises the joystick (i can see it in my System Report), but QGC doesn’t see it. Also, there is not even a “joystick” label in the Parameters.

How should I fix this issue?


Hi @katlea, welcome to the forum :slight_smile:

Have you got a vehicle/autopilot board (e.g. Pixhawk) running ArduSub connected? Once the connection is made QGC should change to the ArduSub interface, which should provide access to the Joystick Setup Page. There should also be a joystick/gamepad icon in the top-bar that’s red if no joystick is connected, and white once a joystick is recognised.

If you weren’t talking about the Joystick Setup Page, I’m not sure what you mean by this.

Hi @EliotBR ! Thanks for your quick response.

I do have a Pixhawk connected. And QGC changes to the ArduSub interface. But the joystick icon is red. I checked in my “System Report” of my Mac and the joystick does appear there, so the problem doesn’t seem to come from my Mac itself.

And everything works fine if I use my colleague’s laptop that runs on Windows.

Indeed, I was referring to the Joystick Setup Page. But I cannot see it when i run QGC on my Mac.


Are you on an M1 Macbook?

I use a PS5 Joystick and it connects without issues on my 2019 (Intel) MBP. I believe we’ve tested the Logitech F710 previously on Macs and confirmed it works, so different hardware type is all I can think of. I’ll ask internally to confirm if someone’s tried the F710 on a Mac, and whether someone’s got an M1 Mac they can test it on.

i’m on a MacBook Air 2020 with an intel core i7. I recently updated the os to Monterey. Another Mac user with the same os has had similar issues.

I’m also on Monterey, so not a blanket issue at least.

Is the switch on the back set to X?

Yes it is set to X. I tried both ways to be sure.

I’ve been told

so if you haven’t already, maybe try restarting your computer? :slight_smile:

Rebooting didn’t work unfortunately… :upside_down_face:
I’ll try with a different controller to see if it’s a compatibility problem with the F710.

Ok, so to summarise:

  • you’re on an Intel-based Mac, running MacOS Monterey
  • QGC is version 4.0.5
  • the controller is a Logitech F710, and you’ve tried putting the switch on the back in both X and D modes
  • the computer is detecting the joystick, but QGC isn’t
  • restarting the computer didn’t help

In a similar previous issue it was explained that QGC uses a particular library (SDL lib) for joysticks, and if that library doesn’t see the joystick then QGC won’t. My current hypothesis is that the version of SDL lib in QGC 4.0.5 can for some reason not detect the F710 on Monterey.

I’ll ask again internally if there are any further suggestions for things to try, but in the meantime can you try installing QGC 4.2.0 (the .dmg) and seeing if the joystick is detected? Unfortunately there’s an ongoing issue with QGC >= 4.1 on Mac that stops the video from working, so it’s not a permanent solution, but if the new version solves the joystick issue then that’s some extra force behind the push to get that video issue fixed, so Mac users can upgrade.

I expect it should at least work with PS4/XBox controllers, and PS5 works on my similar machine on the same OS and version of QGC. Would be great if you don’t need to swap controllers, but it may prove to be the only viable option until the compatibility bug gets fixed, or if it’s already fixed in later QGC versions then until the Mac video bug gets fixed.