Home        Store        Docs        Blog

Second Post: QGC hanging up in Windows

(Earl Chapman) #1

I am having trouble with QGC. It runs for a few minutes and then hangs up. Running in WINDOWS. I can restart but happens again and again. Have tried uninstalling and reinstalling both QGC and pixhawk. No joy. Out of ideas on what to investigate next.

0 Likes

(Earl Chapman) #2

This one was resolved by updating to beta version

0 Likes

(Jacob) #3

Does the application close? or stop responding? Is any message presented?

0 Likes

(Earl Chapman) #4

It just hangs up. I get the little circle I’d call an hourglass and “program not responding” error message. I have to kill QGC and restart, and it starts up fine, but repeats a few minutes later.

Odd thing is that when I originally loaded QGC, it worked fine, but in the quest to get my companion computer working, I reinstalled it, which is when it started happening. I tried reinstalling again, insuring thorough cleaning, but no joy. On a whim, I installed the current daily build version last night and it started working fine again.

Oh…One last point. I am still using an older version of windows, and I have read the posts that I should be on windows 10. Only thing that kept me poking at it is that it used to work, and now with the daily build version it appears to work again. I will upgrade to Windows10 before taking the ROV into the field.

0 Likes

(Jacob) #5

An important point, thanks for the clarity. This is an interesting situation you described.

0 Likes

(Earl Chapman) #6

Jacob…one add…

I’m a retired mechanical engineer and long time sailor. Electronics have always been a mystery to me, so I entered into this to have a project to teach myself new stuff (which I am…more than I want sometimes!). Any suggestions on things to study or read? Thrusters seem to work now. On to lighting and camera next. It’s a fun journey.

1 Like

(Jacob) #7

To learn about the ROV and qgc, I recommend you read ardusub.com and https://docs.qgroundcontrol.com/en/

0 Likes