Home        Store        Docs        Blog

QGC failing to start on Windows?


(Richard) #1

Hey All

Anybody else running (or trying to run, in my case) QGC on Windows 10 suddenly seeing weird behavior? It’s been working well for me for the past year, but just today I’ve been unable to get QGC to even start up. I looked in Event Viewer and found a crash message that mentioned the failing module as ig9icd32.dll which looks like it’s related to Intel integrated graphics OpenGL stuff. I don’t think that stuff changed recently on my PC… in any case, reinstalling QGC, rebooting, uninstalling some minor apps and drivers that I installed recently has not fixed the issue. Anybody else having problems?


(Richard) #2

To anybody interested, QGC does boot just fine in safe mode, but did not remember its prior settings.


(JGreg Kherian) #3

Hi,

i seem to experience the same issue:

  • QGC crashes on startup, with the error regarding failing module ig9icd32.dll in the event viewer
  • QGC in “compatibility mode” also crashes with the error message below (and updating the graphics driver didn t help)
  • But QGC does starts in safe mode.

no idea what triggered this as QGC has been working fine before that…

Richard, did you manage to solve the issue?

Any other opinion?

jean

image


(Richard) #4

Hi Jean

I have not solved this issue (I’ve been able to use a linux machine instead) but I definitely want to. I’ll look into the OpenGLContextProfile error you saw, that seems like a good clue.


(Jacob) #5

These issues are due to poor intel opengl drivers or poor driver compatibility on windows. Safe mode uses software graphics instead of hardware accelerations.



(JGreg Kherian) #6

Thanks both for the input.

didn t really understand the issue regarding drivers, Intel, opengl etc, or why it just turned up now (likely because i ve installed a number of other programs recently, but i m not sure which one triggered the crashes…)

but indeed, running QGC with nvidia graphics instead of the intel integrated graphics works for me!


(Richard) #7

Thanks for the update Jean. How do you make that nvidia-vs-intel selection?


(JGreg Kherian) #8

hi richard,
if you have a separate graphics card, then you can just right click on an application and select run with graphics processor then Nvidia instead of the default Intel integrated graphics!


(Richard) #9

That’s handy. Sadly my afflicted computer is a laptop, no other graphics processor besides the integrated.


(Mikkel Flom Pedersen ) #10

I have just purchased an Intel Nuc NUC8I7HVK2 Hades Canyon with Windows 10Pro for usage for my second bluerov2. AMD Radeon RX Vega M GH graphics so I was sure this would be a good package. 32gb ram and 1TB of samsung ssd, but No. Cant even open QGC. Nothing happens when trying to open the program. Is this something I Can work around or do I need to deliver back the nuc? Please give me a solution for this. I need to make it work or get another system.
Regards Mikkel

-Solved
Qgc did not open in safe or compatibility mode.

Installed the newest intel drivers and now everything works like it should.

  • Thanks Willian Galvani.

(Willian Galvani) #11

Hello Mikkel,

Are you able to run it in Safe or Compatibility mode?
Are the video drivers and Windows updated?


(Richard) #12

In case anybody is interested, in my case the trouble had to do with an app that makes use of GPU functions. It’s called Duet, and lets you use an iPad as a second display via USB. Handy, but not when it cripples other apps on your PC! I ended up figuring this out after I found Fusion 360 was also broken on the same machine, traced it to graphics issues and uninstalled anything/everything relating to graphics and figured out it was Duet by process of elimination.


(Marcus) #13

Same problem here…On two machines…Then I remembered I disabled the default audio on both machines to go to my Bluetooth headphones…once I switched the audio back to default, problem was resolved!


#14

On a new laptop and latest QGC Rev6 I am experiencing the QGC to crash when trying to record. I have tried to run it on both the graphic adapters separatly without any difference, graphic drivers updated, QGC reinstalled.
Another indication i have is the video picture turning grey/ pixalated from tie to time.
Comanion updated - OK. Tested on a alternative Laptop with Win10/ Rev6 tested OK.

Any tips and tricks for further faultfinding?

Lapotop spec:
(Win 10, I7-8750H 2.2GHz/16Gb ram/Nvidia Geforce 1050Ti)


(Jacob) #15

Hello, Does this happen when you push the record button (is there some repeatable sequence of events which will consistently make QGC crash)? What is the folder path that you have set up for recording videos?


#16

Hi Jacob,

This happends when the record button is pressed. The circular “timeglass” Mousepointer icon is spinning for a few seconds then the QGC closes.

Video path recording path is the default one as installed by QGC.

Every time the record button is pressed the QGC crash, In the meantime i tried to open QGC in safe mode, but this will not start either.


#17

Videorecording solved. Changed the save path to C:\ then recording worked fine. I will assume this have something to do with some of the caracters in the file path.

Thanks for the assistance.


(Jacob) #18

Please, @Spipp do you remember what the save path giving crashes was?


#19

@jwalser, I can’t remember the full path but i believe the casuse of the problem was the norwegian caracters in the computer name …/småløk/…

After changing the path everything appears normal.