Home        Store        Docs        Blog

QGC freezes when recording

I’m setting up a new BR2 (delivered mid-december) on a new toughbook (delivered early January), and am having issues recording videos. The program runs just fine otherwise, I have full control of the vehicle and a good video stream, but once I press the red button to start recording the video immediately freezes and the program stops responding. If I force-quit and restart the program it behaves fine, reconnects to the vehicle fine, and I can keep flying as if nothing happened, but every time I press record the program tanks again.

QGC is version 3.5.6
ArduSub companion is version 0.0.178
Pixhawk is 3.5.4
Upload/download test: 81 Mbps/71 Mbps

The laptop in question is a toughbook, Intel i5-8365U 1.6GHz, 8GB RAM running windows 10 pro 18362.267. I’m trying to record directly onto the hard drive, but will also eventually record directly onto microSD cards if possible.

I can’t see any major change in processor activity when I activate recording, it stays around 30-40%.

I’ve tried it on battery and power supply since that came up in one of the troubleshooting guides, same result on both.

I believe the issue is limited to the one laptop because I can fly, stream, and record normally using a Mac that I’ve also installed QGC (same version) on. Videos recorded on the Mac play back normally in VLC. The Mac is running Mojave 10.14.6 on an i5 2.4GHz, 8GB RAM.

Possibly unrelated, or possibly related: I haven’t had much success getting the companion computer to talk to a wifi network (because all the available wifi networks at work have very particular login sequences, so I probably need to bring the whole package home to do that).

Is this something anyone has experienced? Can anyone see the one simple thing that I’ve missed (it feels like this is a ‘one dumb thing’ problem so far, since it works on the other laptop).

Joel,

Run Task Manager next time. Check the CPU, and memory usage when all of that stuff is running. I find with my i5 toughbook (CF-31), the CPU bangs to 100% when running the QGC, and the two sonar (viewer) apps.

Hi!
More tip:
1
If You have a laptop with extra built in graphic card (like nVidia, ATI etc)
Check that QGC uses that instead of motherboard standard.
Either by chosing graphic card for QGC in graphic cards settings, or
try an external display and show picture on this only.

2
Check video format is MP4 (Same as Camera hardware encoding)
This is in QGC under “Settings”, “General”

3
Still not working, try QGC in “GPU Compatiliby mode” and “GPU Safe mode”
That might give a hint to people on this forum.

1 Like

TL:DR driver issue, not fixed yet.

Back at work after the weekend, so here’s where I’m at:

Task Manager doesn’t show my anything useful: QGC running uses about 18% CPU, when I push the record button that drops to 0% as the program freezes. I can’t see any spike just before the crash, it trails off over about 3 seconds.

Changing the recording format to .mp4 gives the same freeze-crash (as indeed does .mov)

The laptop does not have a dedicated graphics card, so I can’t try that.

Starting QGC in GPU compatibility mode gives me a slightly glitchy red ‘ARDUSUB’ logo instead of the camera feed, but which still freezes if I try to record it.

Starting QGC in GPU safe mode gives me the following error message:

Which definitely leads me to think that it’s a driver issue. Next step, try to get OpenGL working - will work on that this afternoon between meetings, and update with progress. The computer is running Intel UHD Graphics 620, which doesn’t seem to be supported by the first, most up-to-date driver for OpenGL I found, and the ‘auto-update’ driver function in Windows doesn’t get me anywhere either.

There are external graphic cards via USB 3 etc
If you have access to test any of theese it would be a way to find where the problem is.

Next update: no success

Not having access to an external graphics card I haven’t yet tried that, but I’ve tried running the video to an external monitor, with the same results.

I’ve also now updated and re-installed the graphics drivers more different times that I can count, including updating via the windows updater, manually updating via Intel’s website, deleting the existing drivers and re-installing fresh driver’s from Intel’s website.

The library files that are listed in the error code are all present in the QGC directory (and also present in the system directory), so I don’t believe there to a problem there.

I’m now exploring using VLC to record the video instead of recording it in QGC. I would definitely prefer to have the pilot interface also recorded, but am not yet sure how that will work out for me - have to get VLC talking first.