QGC Browser Closes when hit Video Record Button

Just installed QGC Latest version for new BR2 with Navigator / Blue OS. On computer with Windows 10 Pro.

When I hit the Video Record Button it closes the whole QGC Browser.

1 Like

Two things to try:

  1. In QGC/settings/Application settings, try different options in “video decode priority”
  2. When starting QGC, try “GPU safe mode” and “GPU Compatiliby mode”

I tried “video decode priority” and no change.

I tried “GPU safe mode” and no browser comes up but when you try to start any QGC says can’t do cause another already running.

I tried on another computer with fresh QGC loaded and that computer has sever lags in video.

Tried uninstalling and reinstalling QGC on both computers. Now browser doesn’t close when hit record but video keeps dropping in and out and record stops. Video continuously drops in and out.

I tried putting on another computer with older QGC and video dropped in and out and finally just stayed out.

I went back to other computer and tried to update Blue OS Firmware again and nothing. Tried re-installing the latest stable version. No change. Tried loading default firmware. Failed. Tried loading 4.0.3 and no change.

Note that in every case the Video window starts out with the video and camera icons but after about 15 seconds from connection to ROV screen flashes and icons disappear leaving simply the Red Record Button and settings icon.

Hi @dtrail,

I’m not sure what’s going on here. Could you specify the QGroundControl and BlueOS versions you’ve tried? No need to include the ArduSub firmware version, as it’s not relevant to the video stream.

It would also be helpful if you can run a network test via the BlueOS web interface (in the Tools menu section), in case there’s a hardware problem causing bandwidth issues or something.

Brand new set up with latest QGC and brand new Navigator. I didn’t originally have the video going in and out untill I tried to redo Blue OS firmware. I’ve tried Official, 4.0.? and 4.1.0. I’ve tried resetting to default.

I ran network test going through 220 meter tether and got 40MB down and 50MB up. Ran short whipped and got 50MB down and 80MB up.

I sent email to support with the following error messages from Blue OS:


I checked and get this running continuously on two computers with latest QGC and on a computer with an older version of QGC.

Those sound like ArduSub firmware versions (which are unrelated to the video). BlueOS is updated via the Tools / Version Chooser page.

If possible I’d recommend turning on Pirate Mode and updating to the latest beta version of BlueOS to see whether that fixes your issue. If it does the issue may remain fixed after downgrading back to the latest stable release (currently 1.0.1).

When I went to Tools/ Version Chooser there was only the one current version.

I will have to try Pirate Mode tomorrow. Can you give me the menu step ladder of how to get in pirate mode

Hi @dtrail
More tips for finding issue:
Check if your topside computer is hitting 100% load when recording starts.
That could be done by hitting “ctrl + shift + Esc” at the same time
If you are at or close to 100% load your pc is the limit.
It could be that your graphic card is not using “hardware acceleration” to do the graphics handling, leading to the processor working to hard.
If this is the case, solution is different with different pc/graphic cards…
A way to try is to shut down QGC, right click on your icon for QGC and chose “run by…” followed by your graphic card.

Another tip, do your camera AND your computer screens resolution work at 1080x1920?
If not, resolution change handling will by tough for the PC.

1 Like

I downloaded 1.1.0-beta 13 and it extracted and pulled all the files then screen went gray with Blue Robotics symbol rotating for over 45 minutes now. Is it supposed to take this long. Afraid to stop but thinking time to power down ROV and reboot.

Please advise.

Rebooted ROV computer and confirmed running 1.1.0 Beta 13.

Video continuously flashing off and on. Only difference is Notification now is “Beacon_IP_FETCH_FAIL” AND “BEACON_DOMAINS_FETCH_FAIL” status code 502

No difference with Beta 13, back to 1.0.1 and no difference.

See video showing the video going in and out and video window in QGC loosing the icons after about 15 seconds. This happens on all computers, old and new QGC.

What’s next?

Hi @dtrail
To clarify, you didn’t have this problem when you were running the Pixhawk flight controller and Raspberry Pi 3 on the same computers so it’s unlikely that it’s a computer or graphics card problem?

Thanks to Geoff a Seaview Systems discussing usb cable to camera issues in his past, led to troubleshooting where I tried adding a spare camera and ultimately determined that the original camera ( new part of BR2 ROV purchase from SeaView) was bad. They are arranging a replacement.

I would still like to know following is normal in QGC:

Note that in every case the Video window starts out with the video and camera icons but after about 15 seconds from connection to ROV screen flashes and icons disappear leaving simply the Red Record Button and settings icon.

This is still the case and without the icons present before or during recording there is no ability to take a snapshot.

Sorry to hear you seem to have received a faulty camera. That said, I’m glad the cause of your issues has seemingly been identified :slight_smile:

That changeover happens when QGroundControl switches from the raw UDP stream to handling it with some MAVLink communication, and is expected.

Snapshots are not a feature we have documented as available, but we have recently found that they are possible in some circumstances. Unfortunately that does not include when a MAVLink-enabled camera stream is being used that does not support snapshots on the camera itself. We’ve reported that as a bug, but don’t have a timeline on if/when it will be fixed.