Home        Store        Docs        Blog

Video freezing QGC 4.08

Hello,

I have a new problem.

The video plays/catches up for 0.75sec and freezes for 0.25sec.

I am not recording, I plugged the ROV straight from the rpi to my pc to eliminate any comms issues…

Upload.download well above 90mbps.

My CPU is at 11%, RPi at 30%.

I had QGC 4.05 and tried to install QGC 4.08 to solve the issue.

I tried a new USB camera, same issue.
Companion and ardusub at latest version.

Here is a link to see the issue: https://youtu.be/SvUYtv7F9Tk

If I put the camera on my Oceanvault - Recorder at the same time. No issue on my Oceanvault - Recorder.

Any idea?

Cheers,
E.

1 Like

Update:

Tried QGC 3.5.4 - same problem.

Tried with different computer - no problem.

Reloading windows from scratch. hopefully it resolves this issue.

Cheers,
E.

1 Like

We have also seen this stuttering in 4.0.8 with latest companion and ardusub. Using an older version of QGC resolved it for now. Be interested if a fresh install of Windows fixes it or if it is something specific to the PC.

Which version did you use?

I have the impression that newer QGC is heavier on the cpu. Can you check the CPU usage with QGC open and connected to a ROV?

Hello all,

I completely erased and reinstalled windows.
Run windows updates until no more were found.

I installed QGC V 4.08 first.

Installed all my other software after.

Problem solved.

I have no idea what caused this issue or why. But working with Windows for so many years, I’ve learned to not try and understand :slight_smile:

Cheers,
E.

1 Like

Etienne, problems were on both 4.0.5 and 4.0.8, we then used the beta release linked here: Software Beta Test Release which seems much better in terms of latency, lack of stuttering / dropped frames etc.

William, when we experience this, CPU is barely above 30% on any cores on the PC and GPU is about 35% (we run using a dedicated NVidia GPU). I’ll try it on a few other PCs here to see if it is machine specific. We have noticed that the latency issue seems to be exacerbated by using PingViewer at the same time but even then CPU and GPU utilisation remains low.

I tried 3.5.4 and had the same issues. For me it was some windows 10 conflict. That was for video preview only. I didn’t try recording.

yo i recomed yousing the QGC 4.0.5 becuse it’s stable and try to lower your resolutio it might be that your computer cannt hedal sutch hige bittrate, and the companion software at 20 pixhawk 3.5.4. hope it works