Home        Store        Docs        Blog

BlueROV2 Heavy camera problem after finish assembly

Hello, i am new to the BlueROV2. I just completed my build heavy version. Everything is working as normal, but i noticed that the camera feed to my notebook has some on off problem as shown in the my youtube clip. Please advise.

Hello,

Please check how is your cpu usage and make sure that windows is not in power-saver mode.

We have some other poor video performance troubleshooting tips at our docs.

I just got the same problems…

The ROV performed flawlessly until the last job. Since then we’ve got a lot of pixelation, a few seconds lag and grey flickering video screen in QGroundcontrol.
I performed all standard checks, even flashed the Raspberry PI with the latest software, switched off all energy saving options in the laptop etc.
When I reduce the video resolution and fps in the camera settings it gets a littlebit better but certainly not perfect like it was before.
Please help!

Has anything else changed software wise?

Try checking the bandwidth in companion. If there were no software changes, it is possible that you have a bad connection or broken wire somewhere.

Have You upgraded QGC to 4.x?
I have same problem there:

Yes I installed QGC to 4.X some time ago.
For now I solved the problem by using a different laptop: 2020 MacBook Pro.
Works like a charm again with nog lag or pixelation…

However I think that it’s strange that on the old Dell Latitude E7440 it worked great, but suddenly it is giving problems.

I think the problem is how QGC 4.x (64 bit) handles laptops with nVidia and other highend graphics.
Problem is the highend graphics is usually “parallell” inside the lapop with the onboard Intel graphics.
Hope new QGC version solves this

1 Like

i like to thank you every one for answer. First, i used my surface pro 6 but now i changed to normal high performance notebook and the problem seem to go away and vdo stream is ok now.