Home        Store        Docs        Blog

QGroundControl Does not Launch


(Jean Filion) #1

I uninstalled QGC and installed the new release.

It no longer launches.

It just spins a loading circle animation for 1 second and then nothing.

I have tried safe mode and all that. Does not load.

I updated my video card drivers. Does not load.

Any ideas? I’m using an AlienWare Laptop running Windows 10.


(Patrick José Pereira) #2

Hi Jean,

Which version are you using ?
You can download the last version available here.


(Jean Filion) #3

I tried the latest version by following your link. Same failure. Here are some additional details that might help:

Alienware 53B6Z52
2.5 GHz Intel Core i7-4710HQ
NVidia GeForce GTX 980M (4GB DDR5 Ram), Intel HD Graphics 4600

The version of the software that worked said: QGroundControl v3.2.4-BlueRobotics-Rev3 in the application name.

Can you point me to that version? I can use that for a while.


(Patrick José Pereira) #4

Hi Jean,

Do you in which video card QGC is trying to run in your computer ?
Is it possible for you to select the one that you want to use ?
To download previous QGC version, check here.


(Willian Galvani) #5

Hi Jean, It seems that your laptop has both integrated and dedicated GPUs.
You can try to switch to dedicated GPU right clicking the QGroundControl executable like this:

But I believe your problem should be solved by updating the intel GPU drivers.


(Jean Filion) #6

I made a big effort to update all graphics and video drivers. It says it’s up to date but who really knows? The start mode did not work. Neither did the right click on executable and select different graphics card. However I do have some good news to report, revision 4 works! Thank you for linking me to the legacy exe. Much appreciated ! I’m back in the water and I love the ROV !!

Rev. 3 works
Rev. 4 works
Rev. 5 fails to load
Rev. 6 fails to load


(Patrick José Pereira) #7

Hi Jean,

This appears to be related with the video render or with the new gstreamer, we did some updates in gst from rev-4 to rev-5. We’ll improve this type of stability issues in the next versions of QGC.


(Jacob) #8

@jfilion Please send a crash dump to support@bluerobotics.com according to the instructions here:
Issues found after update