Last QGC bug

I just wanted to let you know that I installed the last QGC release and although I was happy to see the small airplane pointer changed for an arrow that it does have some issues. I had the io heartbeat error and had to format my sd card and then the troubles really began. The lights did not work and began to blink, the QGC lost connection with the ROV, QGC wouldnt arm. and I could not enter the settings on compass and level indicator in order to display custom parameters like battery voltage… I had the latest daily build and removed that as well as the last QGC and installed the QGC that was released 9/22/16 and installed the stable build of Ardusub 2016-12-30.

Although I no longer have the pointer and Im back to an airplane compass pointer on QGC, but it does work well and in fact all of it works perfectly.

I thought I would share this in case anyone is having similar issues.


Good luck!

Related to the subject of QGround Control bugs, should we report them through the Ardusub Github page ( Pull requests · bluerobotics/ardusub · GitHub ) or where?


If you are certain that an issue pertains to QGroundControl, then the bug should be reported on the QGroundControl github issues page. Otherwise, issues with ArduSub or using QGroundControl with ArduSub in particular may be reported on the ArduSub github issues page.


It looks like some of your issues are with ArduSub and some are with QGroundControl. I will address your issues individually, and distinguish which software they pertain to.

  1. No IO Heartbeat error: This is an error reported by ArduSub indicating that the SD card has a corrupt filesystem. Formatting the SD card should fix this, and it looks like that worked for you.
  2. Lights blinking: This would also be an issue with ArduSub/Pixhawk, and may be fixed with parameter settings.
  3. QGC lost connection with ROV: This is a transient thing that some have been reporting, but I have been unable to replicate it. It could be an issue with hardware, MAVProxy, QGroundControl, or ArduSub. It is interesting that you do not have this issue after changing the software. If you could change back to QGroundControl 3.1 or back to the stable ArduSub, individually, we could narrow down the issue.
  4. Unable to change values to display on compass and attitude indicator: This would be an issue with QGroundControl. I tried with QGC 3.1.1, and do not have any problems on Ubuntu.
  5. QGC won't arm: This is likely an issue with parameter settings in ArduSub.
If you can, it would be great to troubleshoot through these issues so that we can fix things with the software as necessary. The ArduSub gitter would be the best place to accomplish that.




No IO Heartbeat error: This is an error reported by ArduSub indicating that the SD card has a corrupt filesystem. Formatting the SD card should fix this, and it looks like that worked for you.
Except Heinz already reformated the SD card once (in mid December), then updated the ardusub firmware, and the heartbeat issue happened again.

Would it be possible for you folks to test under Windows before putting updates into the “wild”? Both Heinz and I are running into the same issues (we’re both using Windows 10) and it’s excedingly frustrating that every time we update the firmware or QGC we run into new bugs. As for me, the last version I’ve been able to use is the same Summer 2016 version that Heinz is using.


Would it be possible to include links to the bug reporting pages on github for both ardusub and qGC in the docs? My fear is that by not properly documenting these bugs a lot of things are slipping through the cracks and we’re not seeing fixes to bugs we think we’ve reported.

For anyone following this thread, here are direct links to the Github pages:

QGround Control:

ardusub: - I’ve added links to report issues properly to the bottom of every BlueROV2 page on and also to the Troubleshooting page of as well as the bottom of every page.

Thanks for suggesting this! It would be great to get all bugs properly tracked and resolved quickly.


Hey gang, for the record.

Im glad and thankful you all had instructions on how flash the pixhawk and how to fix the No IO heartbeat error. I wouldn’t have known how to previously as I’m not a drone pilot. This has been a learning experience and I"m happy to get the ROV working again and ready to dive.

Muchas gracias.


hey gang I got my ROV running again and I want to post this in case it will help anyone else.

First of all Im fairly certain that is was the pix.#file that comes along with QGC that was the problem.

Im using a new Levono 3&1 laptop with windows 10 and its brand new purchased just for the BlueRov2

I used the QGC that was available and the ardusub that the pixhawk came with and I did dive with it once with almost no problems. Then I saw here that a new stable build of ardusub was available and a daily build of QGC came out to fix some issues. That’s when my problems started. I was loosing signal, lights were not working, the ROV wouldn’t arm, the pixhawk was not happy and had red lights blinking.

To make this as short as possible let me just say that windows users have to go through some special steps in order to get the new QGC installed and the stable build of ardusub.

Here’s what I did to fix my ROV.

I downloaded the latest daily build of QGC and the stable build of ardusub.

When I installed a new version of QGC I went to apps and un-installed it. But when I installed a new version aof QCG a screen popped up asking me to repair or remove the pix.# and the install tab was not available to click for some reason. That I think was the problem since I needed to install a new pix.# file

What I did was buy a brand new 8 GB micro SD card from Best Buy for a whooping $11, since I had already messed with the other one I though I would buy new one and install it in my Pixhawk

Then I un-installed QGC and re-booted my pc

Then I pretended to install the latest daily build of QGC until the screen came up of pixhawk asking me to repair or remove the pix.# file. I choose remove and then rebooted the pc once again.

After rebooting I installed once again the latest daily build of QGC and then it asked to install the new pixhawk file on the pc. Which I did and it looked like a brand new install and then it completed the installation of QGC as well.

I connected the pixhawk directly to my pc via a micro usb to flash the pixhawk. Please watch Jacob’s step by step procedure for flashing one. I installed the stable build of ardusub and the parameter files. After thats all done the joystick is disabled and will have to be calibrated then QGC will work.

Now it all works beautifully. I did loose connection a few times for just a split second but it seems that is not an isolated problem and it re-connects immediately.

So my thoughts are that since I was not able to install the pix.# file since the screen menu wouldn’t let me I was just repairing and that left and incomparable file in place. I powered and de-powered the ROV for about 10 times to verify that all worked well and it did.

Good luck!



It’s all fixed now.



Hi Heinz,

Thank you very much for the update, that is useful information. I’m glad you’ve gotten it working. Can you please clarify what the ‘pix.#’ file is, or where it was located on your computer? The ‘pix.#’ file is not the same thing as a .px4 firmware file, correct?



Hi Jacob, the file that Im referring to was not firmware but software and is called “PX4 driver” and it only came up when I tried to install a new version of QGC. If I have QGC already installed on my pc and try to install a new version of QGC instead of getting the “welcome to PX4 driver and where would you like to install it screen” I got another screen with 3 options which are 1.Install, 2 Repair, 3. Remove. However, the problem I had was that the option 1 was not available and was opaque and I couldn’t click on it so I had previously choosen 2. Repair since thats all I had available. But now I realize that was an error as I needed a new PX4 driver file. That’s why I posted the method I used to remove the PX4 driver and to install it with a new version of QGC.



Thank you for the clarification. This is something we will have to look into.