Home        Store        Docs        Blog

QGC doesn't show vehicle connection


(John Griffiths) #1

I recently encountered a problem with not being able to get QGC to show vehicle connection when connected through the tether although video was showing. When I connected the pixhawk to my laptop via usb, there was no problem. Thinking that it must either be an issue with the raspi or pixhawk, I installed a complete new electronics package but have found exactly the same problem suggesting strongly that the issue lies elsewhere. i have the latest QGC installed, a brand new electronics package so should be able to rule those out as the source of the problems. I need to get this ROV up and running so would greatly appreciate if anybody can offer insight into what might be happening.


(Jacob) #2

What OS are you using?

Can you please open a command prompt and show the output of the command ipconfig (Windows) or ifconfig (Mac)?


(John Griffiths) #3

Hi Jacobthanks for getting back to me. I am running mac sierra 10.12.3 on a MacBook pro.command prompt yields this. not sure if makes any sense to the issue.John maxage 0 holdcnt 0 proto stp maxaddr 100 timeout 1200 root id 0:0:0:0:0:0 priority 0 ifcost 0 port 0 ipfilter disabled flags 0x2 member: en1 flags=3<LEARNING,DISCOVER> ifmaxaddr 0 port 5 priority 0 path cost 0 member: en2 flags=3<LEARNING,DISCOVER> ifmaxaddr 0 port 6 priority 0 path cost 0 nd6 options=201<PERFORMNUD,DAD> media: status: inactivep2p0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 2304 ether 02:a6:37:ed:34:fd media: autoselect status: inactiveawdl0: flags=8943<UP,BROADCAST,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1484 ether 62:16:60:c3:ee:b4 inet6 fe80::6016:60ff:fec3:eeb4%awdl0 prefixlen 64 scopeid 0x9 nd6 options=201<PERFORMNUD,DAD> media: autoselect status: activeutun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 2000 inet6 fe80::d92e:a04d:565e:86b7%utun0 prefixlen 64 scopeid 0xa nd6 options=201<PERFORMNUD,DAD>Johns-MacBook-Pro:~ johngriffiths$


(Jacob) #4

Can you please power on the Rov, connect it to the computer, and go to 192.168.2.2:8088 in a browser. Click open terminal and in the terminal enter the command ‘screen -r mavproxy’. Please let me know the output.


(John Griffiths) #5

I cant get that IP address to open in either Safari or Chrome because they say the server isn’t responding. that indicate anything? I entered the command in terminal anyway and that says Johns-MacBook-Pro:~ johngriffiths$ screen -r mavproxyThere is no screen to be resumed matching mavproxy.Johns-MacBook-Pro:~ johngriffiths$


(Jacob) #6

Is video coming through in qgc while you attempt this?


(John Griffiths) #7

no video coming thru although it was showing yesterday.


(Jacob) #8

Ok, it sounds like either the network settings on your computer are not configured correctly, or a physical issue with the cables. Please email support@bluerobotics.com, and I will help you resolve this more quickly.


(Patrick Keeling) #9

I just completed a new build and have the same problem as described above. Using a Makbook pro El Capitan (10.11.6). Using a thunderbolt ethernet adaptor. It appears to have connected and when I power up the topside board and the ROV the video comes through, but it says “Waiting for vehicle connection” in red over the top of the fly window in QRground control.

I followed Jacob’s instructions above and went to 192.168.2.2:8088 in a browser and opened the rpi terminal window and entered the command ‘screen -r mavproxy’. It showed this:

Connect /dev/serial/by-id/usb-3D_Robotics_PX4_FMU_v2.x_0-if00,115200 source_syst
em=200
Failed to load module: No module named terrain. Use ‘set moddebug 3’ in the MAVP
roxy console to enable traceback
Failed to load module: No module named adsb. Use ‘set moddebug 3’ in the MAVProx
y console to enable traceback
Listening for GPS Input packets on UDP://127.0.0.1:25100
Loaded module GPSInput
Outputting depth on UDP://0.0.0.0:25102
Loaded module DepthOutput
Log Directory:
Telemetry log: mav.tlog
MAV> Waiting for heartbeat from /dev/serial/by-id/usb-3D_Robotics_PX4_FMU_v2.x_0
-if00
online system 1
MANUAL> Mode MANUAL
fence breach
APM: ArduSub V3.5.1 (28fdbf65)
APM: PX4: 8d505a02 NuttX: 1a99ba58
APM: PX4v2 00230031 3336510B 36353335
Flight battery warning
Received 691 parameters
Saved 691 parameters to mav.parm

Eventually it also added “Flight battery warning”, although I checked the voltage of the battery and it was still at 4.1 per cell. I am not using the battery it cam with, but a 4S 5200mah 25C lipo.

Any suggestions would be very welcome. Thanks!


(Jacob) #10

In QGC, make sure the UPD auto-connect option is selected in the General Settings menu (click the ‘Q’ icon).


(Patrick Keeling) #11

Yes, that is checked (all the auto connect options are checked). Any other ideas? Thanks for replying quickly!


(Jacob) #12

Please open a terminal and enter this command : nc -ul 192.168.2.1 14550. Press enter a few times, and let me know if there is any output.


(Jacob) #13

Whoops, close QGC first.


(Patrick Keeling) #14

No output. The cursor goes down a line but no other response.


(Jacob) #15

@Keelinglab, please email support@bluerobotics.com to get in touch with me directly.


(Jacob) #16

The problem here turned out to be that the netmask was not configured correctly on the surface computer. It was set to 255.255.0.0 instead of 255.255.255.0.