Home        Store        Learn        Blog

Vehicle connection - No connection during test

Hi
I am trying to connect QGC to a mock-up consisting of a RPi and Pixhawk. The system is connected to the computer via ethernet from the RPI to the computer. At this stage, this is the whole set-up. Is this enough for QGC to “connect to vehicle” ?
QGC has been given access through fire-wall

ip address and sub-net are according to the set-up.
IP on computer
image

I did a network test that looks ok

Versions (pixhawk updated)

If you have a firewall or any antivirus program, you can try turning it off.

If the problem is not solved, you can connect to companion with putty or web interface and use screen -r mavproxy commands to get information about pixhawk. If you post results later here. We can try to understand what the problem is.

I powered the RPi using a DC power supply in the workshop. I powered the RPi through the pins and not through the usb micro. Changing from the pins to power through the usb micro, it suddenly worked. I have no idea why as all the lights and all was appearing the same as before when power-up…

1 Like