Home        Store        Docs        Blog

ROV failure to connect in QGC


#1

Have been having a connection issue with our ROV today also. It has been connecting and functioning fine up until today. There is no new equipment differences since the last time we used it.
I have tried rebooting the topside, the ROV, and QGC several times.
I switched out the FXTI USB cable.
I switched batteries in case it was a low battery fault.
I reinstalled QGC. Can’t reinstall firmware because I can’t connect to the ROV. Can I plug directly into the ethernet boards with my laptop?
I opened the pressure vessel and ensured that all connections were still good and there wasn’t anything burned up looking.

Pixhawk LEDs are as follows:
FMU PWR=solid green
IO PWR=solid green
ACT=flashing blue
Main LED=flashing blue
On start up it makes the usual beeps, the lumen lights flash, etc.
Also, on start up IO B/E is solid orange.

My FXTI has green Power and Link Active lights.

The Fathom X Tether Interface board on the ROV has solid green PWR and Link lights. The ethernet port on this board has flashing orange and green lights.

The board under the Pixhawk with the other ethernet port has one solid orange and one flashing green light. It looks like it also has a solid red ACT light and a blinking green PWR light on the board itself.

The voltage regulator boards on either side have solid red LED lights.

The Power Sense Module has a greed LED.




(Dale) #2

You plug directly into the Pixhawk via Ethernet. That will rule out comms, or fathomX failures pretty quickly.

D.


#3

Thanks, we are plugging in through the fathom x tether interface, but im buying an ethernet to usb converter today to try it. No ethernet port on the laptop and its not working through Wi-Fi.


(Rusty) #4

Hi AlaskaSubmarine,

It sounds like you’ve been pretty thorough here and I appreciate all the screenshots. A couple more things to check:

  1. Do you have any other software that might have a firewall like another Antivirus program?

  2. Have you tried on any other computers? If available, that’s a good option just to make sure the ROV is actually working fine.

  3. Can you also check that the lights are showing on the Raspberry Pi? That’s where the network connection is actually routed so the Raspberry Pi has to be running fine for anything else to connect. If it’s not powering on, it could be a power supply (BEC) failure.

If this keeps happening, shoot us an email at support@bluerobotics.com and we’ll figure out what to do.

-Rusty


(Mariya Channiwala) #5

You may have already visited this, but please review the suggestions here:
https://www.ardusub.com/troubleshooting/troubleshooting.html#no-telemetry-no-pixhawk-connection


#6

Thanks for the input Rusty,
The issue seems to have self-resolved as I have a video feed in QGC again. Since I reloaded QGC, I have to reset all the settings and re-calibrate. I will let you know how this goes tomorrow.
Regarding your questions:

  1. No other software, or changes to the original software which has been working since we purchased it last month.
  2. I haven’t tried another computer yet but have access to one I can load QGC on and check.
  3. On the RPi the PWR light is solid red, the ACT light is flashing green (I-I—I---I-I—I---I-I—I---…)
    The ethernet port has a flashing green and a solid orange. I don’t see any other lights active on it.