Q Ground Control App installed fine and opened but can't find it in Control Panel Apps to allow Windows Defender Firewall to allow it

Hello Techwizards,

Q Ground Control App installed fine and opened, looks pretty but can’t find it in Control Panel Apps to allow Windows Defender Firewall to allow it. So Q Ground Control is still “Waiting for vehicle connection”
It doesn’t come up in the app list, if I then connect “Allow another App” it doesn’t appear. Browsing for it still doesn’t come up in the list.

“Open Source Q Ground Control App dev by ……” does not come up in the list.

So…take 2,

Now trying it on a different laptop (Macbook air with windows installed) the computer asked to allow the app which I did but it still is “waiting for vehicle connection”.

BlueRov2 is turned on, connected by the tether to the Topside interface, lights are on in the BlueRov2 and interface, USB is connected to the laptop. Q Ground Control is open but no connection.
Solution is probably something simple but please any suggestions would be welcome


Any ideas?

Macbook Air doesnt have an ethernet connection in the list so I think I may need an adapter but my Dell PC does but that doesnt work.

Probably something simple?

It says that " Q Ground Control can upgrade the firmware on Pixhawk devices, SiK Radios and PX4 Flow Smart Cameas. Plug in your device via USB to start firmware upgrade."
Should I be plugging a cable directly into the Pixhawk from the computer??. I currently have the computer connected by the USB to the Fathom X tether interface to the tether spool and through to the BlueRov2. Also noting that the tether has 3/4 wire sets not connected (6 wires).

Hi @ScubaDog, Can you access the companion web interface at ?

Sounds like you need to figure out where you installed QGroundControl so it can get added via the Allow Another App… functionality. If you aren’t seeing it when browsing there but it is installed, you likely aren’t looking in the right spot of the directory structure.

Hi William, unfortunately no I cannot access the companion web interface by clicking the link you posted above

Hi @ScubaDog,

Is the .3 a typo?

Anyway, it looks like your networking is not properly setup, check our troubleshooting guide for some tips.

yes that was a typo :wink:

I went through the troubleshooting guide again.

Interestingly Etcher had a problem on both my PC and my MacBook air when trying to flash the scandisc SD card from the Raspberry Pi , however it had no problems with the .img file and flashing a new Toshiba SD card.

Still cant find the QGround Control App in the list of Apps when attempting to allow communications.

On the Ground Control App, when my PC was pluged directly into the Pixhawk it communicated, even asking to go through the compass and accelerometer calibrations but I cant do that with the housing off.

Unfortunately when putting the BlueRov2 all back together, plugging the battery in and plugging the tether>>fathom topside interface (FXTI both lights green) through to the same USB port on my PC as before, the computer sounds that its received a link but QGround Control still says “Waiting for Vehicle Connection”.

You will likely have to select the executable manually. It is Usually located in C:/Program Files/QGroundControl/QGroundControl.exe IIRC

You can use Windows’ Resource Monitor in the Network tab → Listening Ports section to check if QGC is being allowed to listen the ports it needs ( it should show “Allowed, not Blocked” or similar).

But you have no access to the Raspberry PI. It means that either it is not booting or there is a networking issue.
Check that the FXTI interface is set to, the wiring is correct, and that the companion booted properly (it should have at least one green led on).

I had the exact same problem, Firewall did not list Qground, no connection… network OK…It was a nightmare, uninstall, clean up registers, install etc again and again never solved the problem on one windows 10 workstation, went to another…
Suggest to re-install win 10, clean install if you have the time …

Thanks William & William.

I think I might have to buy a new computer just to get this going. Both computers I tried are 5 years old and the Dell PC is really tired. The MacBook Air has been wiped and reloaded with newly windows just before I tried to achieve this connection and didn’t work. It appears that it might not be able to handle it too. My understanding is that even if you delete files on an old computer they’re basically still there until they get overwritten.

Need a new computer anyway to edit videos so looks like it will be an IMac Pro desktop and maybe a Panasonic Toughbook 55 for the field.

I’ll try William Galvani’s suggestions first but unfortunately will have to keep using my other drones for the time being.

Thanks guys for your suggestions and info.

I clicked on the companion web interface just now and it doesn’t connect. I cannot currently access it although I don’t have the BluRov connected to this computer at this time. Does this mean anything Willian?

I have resigned to the fact that I probably need to purchase a new laptop computer to get the BluRov to work. That’s okay though as I need a new one anyway. This Dell Laptop is 2014, is very slow and wont back up.

The companion web interface is hosted by the Raspberry Pi inside the vehicle, so you need to be connected to the vehicle to access it.