BlueROV2 Connectivity Problems

Hi all,

I have a BlueROV2 and I am struggling to connect the ROV to the QGroundControl program.

It appears to provide a live video on the QGroundControl program but does not state that it is connected (e.g. no functions, no green parameters bar and no vehicle found in the “Vehicle Setup” menu).

Unlike previous forum discussions, I do not receive the message “QGroundControl can upgrade the firmware on Pixhawk devices, sik radio and PX4 flow smart cameras. All QgroundControl Connections to the vehicle must be disconnected prior to firmware upgrade.”

Below are some dot points of what I am experiencing, including troubleshooting methods as described in

  • When the battery is connected, there is an initial beep.
  • When the ROV tether is connected to the fathom X – there are green lights for “power” and “link active”, however no secondary beep.
  • There is no connection between the ROV and QGroundControl software (no green parameters bar and no vehicle found in “Vehicle Setup” menu), but able to receive live video from the ROV.
  • Network settings are correct (Ethernet IP address and the subnet mask
  • Able to ping using the command “ping”
  • I have made a rule to allow inbound and outbound traffic on UDP ports 5600 and 14550
  • “MAVProxy” is listed under active services when using the systems page
  • Using web terminal, it appears that MAVProxy and the autopilot are not communicating as the command “screen -r mavproxy” returns “failed to connect to” followed by “could not open port”

Any advice would be greatly appreciated.

Many thanks,

Hi @HamishC, welcome to the forum :slight_smile:

Sorry to hear you’re having issues connecting to your ROV, and thanks for the details on what you’ve checked and tried so far - it definitely helps to narrow things down.

The video stream and MAVLink (telemetry/controls) communication use separate channels, so it’s not uncommon for one to work properly even while the other is failing.

Is this the full set of 5 beeps from each ESC/thruster (three short rising beeps, followed by two longer rising ones)? The initial three indicate that all three phases of a thruster have been detected, and the two longer ones indicate that a valid and neutral PWM signal is being received by the ESC (from the flight controller).

If the later pair is not sounding then your flight controller may not be working properly, in which case you may need to open your enclosure to see whether anything is unplugged, and if all the connections seem fine then try turning on the vehicle and seeing whether any of the Pixhawk’s power and status LEDs light up.

  • If the IO “PWR” LED (on the right) is not lit up then the Pixhawk is likely dead, in which case I’d recommend contacting to discuss appropriate next steps (if you do so, please include a link to this post, and if possible your order number or approximate order date)
  • If the FMU “PWR” LED (on the left) is not lit up then the Pixhawk does not have a powered connection to the Raspberry Pi, in which case you should double-check the USB-microUSB cable (and potentially replace it)
  • If the PWR LEDs are both on, but the big status LED is not flashing blue and the B/E LEDs are flashing red then please try connecting your Pixhawk directly to your computer running QGroundControl (via a USB to microUSB cable) to flash on ArduSub
  • If the big status LED is already flashing blue approximately once per second then the Pixhawk is likely working fine, in which case you can try changing the USB port the cable is plugged into, and swapping out the cable, and if that doesn’t help there may be an issue with the Pixhawk’s microUSB port (I’d recommend contacting the support email here)

That does make it seem like an issue with the connection between the Pixhawk and Raspberry Pi rather than somewhere else. I’d suggest going through the checks above, and if that doesn’t help then please contact the support email :slight_smile:

Hi Eliot,
Thanks for the recommendations. It appears that it may be an issue relating to the microUSB port (tried changing USB port and different cable).
Additionally, there is a blue flashing “ACT” light on the Pixhawk.

I shall contact the support email.


1 Like