Can't connect to Qgroundcontrol

So, I have a companion Pi connected to Pixhawk and am running fathom interface.

I have installed the companion computer software.

I have installed sub 4.03 on the Pixhawk.

When I run the companion interface, I can see the Pi is connected to the Pixhawk. I can even reboot the Pixhawk via the companion computer interface.

When I run QGC, I can’t get a connection.

I have my PC set on

There appears to be no actual instructions on setting up the QGC connection - if there are, it would be great to get a link.

I have created a connection in the COMMS tab at but it won’t connect.

I did not see any instructions on setting the board rate between the Pi and the Pixhawk. What should it be? I assume the latest companion software and the latest SUB firmware would have the correct baud rates defaulted.

That said, I assume that if I can reboot the Pixhawk from the Pi, they must be talking.

Any help appreciated.

Hi @ausdroid,

If both the video and telemetry aren’t appearing then most likely you need to allow QGC through your firewall :slight_smile:

If that doesn’t help, have you gone through our troubleshooting steps? If so, what were the outputs / results?

QGC should connect automatically to UDP connections on port 14550 by default, but it needs to be allowed (through the firewall) to do so.

I can ping from my laptop which is sitting on

I will make the changes to the firewall later today.

Also, I was not able to see any wireless SSIDs on the companion computer browser page so had to manually install Sub through USB.

Is the wireless activated by default on the companion computer software? If not, how do you turn it on?


It should be enabled, yes.

A few questions:

  1. Was your Raspberry Pi inside something like a metal enclosure while you were trying to connect to wifi, or far away from your router?
  2. Have you considered BlueOS (instead of Companion)?

If you’ve decided against using it,

  1. Which Companion version are you running?
  2. How did you install it?

Hello Eliot.

No. The Pi was not inside a Faraday cage.

I installed what I assume was the latest version of companion by downloading the image and using Etcher to write the image to an SD card.

I am happy to flash with BlueOS, particlularly if it can stream multiple cameras - I have three - forward USB, forward hi-def zoom IP camera and rear wide angled RPi camera. I have four enclosures.

I would understand that QGC can only connect to one camera - the plan is to view the others on a seperate laptop.

Hello again.

So, I flashed an 8G micro SD card with BlueOS. The verification worked. I then loaded it into the pi, and no success.

I can ping

But QGC does not pick up a connection.

I have made the changes to Windows Firewall.

When I attempt to open a browser at it can’t connect and I do not get any console.

I’m beginning to question the Pi.


That should work, assuming your cameras have H264 encoded streams, and your connection has sufficient bandwidth to stream all three simultaneously.

Note that in BlueOS

Generally if pinging works then the web interface also works (for both Companion and BlueOS), so that’s unusual.

It’s perhaps worth noting that the BlueOS interface uses different pages and ports to the Companion one - default connection to the BlueOS interface should be at or http://blueos.local (no extra port or page/route specifiers).

Also, are you certain the IP you’ve set is for the connection to the vehicle? If you pull out the vehicle connection while looking at the available networks the one you’re after should change to showing as disconnected and/or should disappear.

If it’s pinging back then it’s unlikely to be an issue with the onboard computer, although you can ssh in to check if you want. User is pi, and the default password is companion on Companion and raspberry on BlueOS.

Are you able to try a different topside computer? Others have had antivirus issues, and occasionally just unknown problems with a particular device.

Thanks for your help. This is ow solved - dodgy US connector between Pi and Pixhawk and bad partions on SD card on Pi.

I now have next stage problems but will open a ew topic.

1 Like