Problems with MAVlink from Onboard Computer

Thank you! I’ll give it a try shortly and send you the new screenshots.

I’ve updated to the new image but unfortunately when I try to access the web interface I only see a blank page. This is all that shows up in the page source:

This is new to me. Can you try acessing the page from different URLs (e.g.: 192.168.2.2, companion.local) or a different browser?

I’m not able to access it from companion.local or 192.168.2.2. I’ve tried multiple browsers and haven’t had any luck. I took the sd card out and re-imaged it. It loaded fine and I tried applying your custom image again but unfortunately I’m getting a blank screen again and I’m unable to access anything.

Good news, @williangalvani has probably solved the problem!

We found out that mavlink-router is not handling correctly multiple connections on the same server endpoint. This was leading to racing issues between video, mavlink2rest and QGC connections. To fix this, we changed Mavlink2Rest to a dedicated client endpoint, and we ask you to use QGC on the GCS Client connection, instead of the Server one.

You can try those changes on the latest BlueOS update, which fix this problem and also includes a logging save system, so no need to take screenshots of the logs anymore :smiley:

1 Like

Thank you so much for all your hard work!

I updated to the latest version and did some more testing today. Unfortunately, the issue still persists. I can always get it to connect after a few restarts but it still seems random as to when it will and won’t work.

I’ve taken a few more screenshots. The following are from an “unsuccessful” start up.



And these are from a “successful” start where everything works as expected:



I don’t know if any of that helps but let me know if there’s any more info I can get for you.

I’m also getting the following notifications non-stop when powered up. I’m not sure if it’s relevant because the same notifications show up whether or not the link is working correctly.

Thanks again to all of you for your help. Sorry for all the trouble.

Are you on master?

can you share what your endpoints look like? (Autopilot → Endpoints)

Yeah, I’m on master. I pulled it yesterday around 5pm PST. Here’s the version number:

Screenshot 2022-02-15 105444

And here’s my endpoints. Let me know if anything looks incorrect.

Overall, I think this new version is working better than before. Everything works correctly most of the time but there are still random cases where it doesn’t want to connect. I wonder if there is an issue with the autopilot firmware. I’ve tried a few different ones: latest, beta, and some of the daily. They all seem to work about the same but let me know if there is one that is preferred.

We’ve made a lot of improvements regarding the board recognition logic on the last releases. Let us know if the last version improves what you were experiencing.