Home        Store        Learn        Blog

No Mavlink thru tether

I have been through all the troubleshooting instructions, updated software / firmware etc any number of times and I’m losing the plot.
Mavlink shows thru traffic with a direct USB lead connection to the pixhawk, but as soon as I try it thru the tether mavlink shows ‘Not connected’. Video comes in good straight away, but ‘waiting for vehicle connection’ message stays on screen. Pinging 192.168. 2.1 thru the tether and fathom-x all good.
Update: In QGC if I try to connect using the Comms Links tab I get message ’ Error on Link Serial device on. Error connecting. Could not create port. The system cannot find the path specified.

Hi @AKABiggles

Ok good troubleshooting so far, here is what I can determine from your post:

  1. You have a good connection to your Raspberry Pi if you have video
  2. You have a good direct connection to the Pixhawk via a Micro-USB cable

Therefore, I recommend the following from the ArduSub Troubleshooting steps:

  1. Verify QGC Autoconnect settings. Verify the UDP option is checked.
  2. Verify Autopilot USB Connection. See if the “Pixhawk Autopilot” shows up in the detected serial devices.
  3. Try a new USB cable between your Raspberry Pi and the Pixhawk. Sounds dumb, but cable hardware issues happen.

Hi Kevin,
many thanks for the rapid response.
QGC autoconnect was checked OK, Pixhawk Autopilot showed as good.
New cable made no difference but I had already decided to re-flash the micro sd in the PI. Once done and replaced I had a good connection, but obviously had to set up joystick etc from scratch. All seemed good, but I wanted to increase the tilt range on the camera, I went for 50 deg each way, and now Camera tilt is not working.
Once I get to the bottom of this little problem I only want to get the Ping 360 working, followed by a GPS that shows my position on the water surface. At the moment the ping is not being seen by pingviewer, ( it was OK before I lost comms). However. one thing at a time, eh? I have tried swapping the outputs from the pixhawk from lights to camera tilt, making the tilt command operate lights, but the tilt servo does not respond. I have spare servos from my drone activities, and they do not respond when plugged into the pixhawk.
I would welcome any suggestions, since my head is about to cave in.

Hi @AKABiggles,

Do you have power (+5VDC) on the servo rail of the Pixhawk? The tilt servo is the only device that requires it.

Yes indeed +5vdc is present. Just lost video on the last reboot, but comms shows OK…
Update: For reasons I have not yet discovered, the camera tilt had somehow been disabled during my attempted adjustments. Video came back at the next reboot - has been good for the last five reboots, so I’m getting a bit more confident. Ping360 is looking good too, can’t wait to get it in the water and see what it performs like. So my only outstanding issue is how to get GPS hooked up and showing on screen (for surface positioning only). By the way, how does one get the sensor panel on the right of the screen to increase in size? I remember it was much bigger by default, but now it’s not so easy to read at a glance.

So my only outstanding issue is how to get GPS hooked up and showing on screen (for surface positioning only).

You’ll need to find a compatible GPS sensor and then the serial and I2C lines go into the appropriate ports: ArduPilot: UBlox GPS + Compass Module

A suggestion, figure out a way to waterproof and mount the GPS on a mast, if that is what you want to do. GPS’ mounted internally do not work.

Hi Kevin,
many thanks for your solid support. It has been great just knowing there was a guru to lean on when it all started to overwhelm my knowledge base.
I had already read thru the thread on the GPS installation, and I have this unit ordered from eBay, should be here next week
UBLOX NEO-M8N GPS Module Electronic Compass w/Shell Fr PIX PX4 Flight Controller.
I had figured it would be better to trim some of the internal chassis to allow the GPS unit to be mounted the correct way up at the top of the enclosure, instead of sideways as seen in the pics. For me, that would be preferable, as there would be potential snagging issues with an external mount. What do you think?
P.S. Any way I can make the info panel at the right of the screen as big as it was a while back?

If you keep a GPS inside the WTE, it will have very limited reception. It may work, but you’ll need to “pop” the ROV out of the water a little to get a fix. Any water over the WTE and you won’t get a signal.

You can change the text size in QGC v3.5.2, but not the rest of the UI. I’ve seen this issue when going back and forth between different screen resolutions. Example: I’ll load it up on a laptop with one size resolution, then dock it with an external monitor with another resolution. Then the UI will change sizes. The only thing you can do is uninstall and reinstall on the primary screen you want to use.

Or were you thinking of something else?

The QGC dailies have a UI scaling feature, but those aren’t stable right now (like instantly crashing).

Hi Kevin,
the GPS unit arrived, and yes it worked initially, but then it started to drift, and after short while it dropped out altogether. Despite my best(!) efforts, I have not been able to get it back. Is there a list of the settings available? I have tried a whole load of the different recommendations on the various forum threads, and I am sure now I have one or more settings screwed up.
I am not expecting any position results unless the vehicle is ‘popped’ out of the water. All I would like is for me to be able to see the vehicle surface position on the map before diving (shallow water, <10m)

If the GPS position drifts its probably due to environmental considerations which lead to a poor HDOP or VDOP.

I wouldn’t recommend changing the GPS settings, but here they are: ArduSub GPS Parameters

If things get too weird, you can Re-Load BlueROV2 Default Parameters.

Many thanks for your top advice. I reloaded the defaults, changed the GPS receiver to a higher quality item, and now everything is just the way I want it, ready for the next trip to the river Tiber in Rome. Many thanks for your patience and support.

FIXED IN ALL DEPARTMENTS !

1 Like