Home        Store        Learn        Blog

Pixhawk is not recognizing pressure transducer

Hai,

I am working on pixhawk and Rpi. I have flashed ardusub in pixhawak calibrated compass and acceleration. When I tried to calibrate pressure transceduer it prompting as pressure sensor is not connected. It also prompting leak detected. When I tried to power on RPi from pixhawk it is powered on but camera connected to RPI is not activated.

Hi @shakeera, welcome to the forum :slight_smile:

ArduSub expects a connection from an I2C depth sensor like our Bar30, and a leak sensor in AUX 6. If you’re running just a Pixhawk and RPi without those sensors connected then the behaviour you’ve described here makes sense.

The Pixhawk is intended to be mostly a power user with signal outputs, not a power provider. I’m not sure how you’ve wired up your setup, but it’s possible the Raspberry Pi has insufficient power.

When you say the connected camera “is not activated”, what do you mean? How is your software set up, and which camera are you using?

Thank you Eliot for quick response…
I have connected 1.6MPa Stainless Steel Pressure Transducer Sensor to I2c port of Pixhawk but it is not recognizing …For RPI I have flashed ardusub rasibian image and pixhawk ardusub. I have used CSI rasbperry pi camera.

Most likely your sensor isn’t compatible with ArduSub by default. I^2C is a communication protocol that specifies the voltage levels and timings of messages, but each device still has its own unique messages. Our Bar30 and Bar100 are both compatible with ArduSub because their sensors are supported in the ardupilot barometer library. If your depth sensor isn’t available there you can add it yourself, or you can use a different sensor that’s already supported :slight_smile:

The camera should be able to stream a Raspberry Pi camera with our normal companion image. How are you checking for the stream? Have you done the relevant network setup for your top computer?