Home        Store        Docs        Blog

Can't switch to depth hold mode


(ooyama) #1

QGC displays MAV_CMD(11) command failed and I’ve already connected the bar30 cable to I2C port


(Jacob) #2

It sounds like your pressure sensor is not recognized by the autopilot. Which version of ArduSub are you using? Try using the latest version. You can check if the pressure sensor is connected properly, by checking the ‘Mavlink Inspector’ from the Widgets menu in QGC. If the pressure sensor is connected and operating correctly, you should see a field called SCALED_PRESSURE2 in the mavlink inspector.

-Jacob


(ooyama) #3

Thank you! But there is only one field called SCALED_PRESSURE


(ooyama) #4

But if I did disconnect the I2C port, the QGC displays PreArm: Barometer not healthy


(Rusty) #5

Ooyama,

Can you verify that the Bar30 cable is plugged into the Pixhawk properly? It sounds like it is not being recognized.

-Rusty


(ooyama) #6

yes, the port is anti-reverse



(Jacob) #7

What version of ArduSub are you using? You can find out by going to the parameters page, and selecting refresh from the Tools dropdown menu. Then click the blue megaphone icon in that appears with messages.

Please copy the line that looks like this: ArduSub VX.X-xxx (abcd1234) .


(ooyama) #8

Hi jacob,

Here it is.

ooyama



(Jacob) #9

Your firmware has an issue with the initialization of the pressure sensor that appeared in the master branch for a couple weeks. There have been a lot of changes in ArduSub over the last month, but now we have a stable release candidate. Please update your firmware.

-Jacob


(ooyama) #10

Thank you very much!


(Haider Iftikhar) #11

@jacob, i am also facing the same problem even after installing the lastest version of ArduSub, can you please help me out?

Thankyou


(Haider Iftikhar) #12

do i need to change something in the parameter list to get this thing working?


(TCIII) #13

@Haider,

When you have QGC communicating with your ROV you can use the MavLink Inspector, which is in the Widgets Tab, to view the Pixhawk parameters in real time.

If your pressure sensor is being detected by the Pixhawk firmware you should have two Scaledpressure parameters showing in the Mavlink Inspector. Scaledpressure2 is the outboard pressure sensor. If Scaledpressure2 is not visible in the Mavlink Inspector then the outboard pressure sensor is not be detected by the firmware. Note, Scaledpressure2 is farther down the list of parameters in the the MavLink Inspector and is not grouped with Scaledpressure1.

Also, be sure in the GND parameter group that the secnbaro is the primary pressure sensor and not the firstbaro.

Regards,

TCIII AVD


(Jacob) #14

Haider,

Has the pressure sensor ever worked for you (prior to updating)? Could you please provide your current ArduSub firmware version, and verify that the BAR30 cable is plugged in correctly.

 

-Jacob


(Haider Iftikhar) #15

@Jacob, yes the sensor worked fine with the Arduino but not with the ROV. The sensor is plugged in correctly.


(Haider Iftikhar) #16

I am only seeing Scaledpressure on MAVLink.

I really need this problem to be solved ASAP, i have a competition in March and i have alot of work to do but very less time.


(Haider Iftikhar) #17

@ooyama, Ooyama? was your problem solved or still facing the same issue?


(Jacob) #18

Haider,

Can you please let me know the ArduSub firmware version you are using, according to the directions I gave Ooyama above? Did you use a logic level converter when using the sensor with the Arduino, or did you connect the sensor directly to the Arduino?

-Jacob


(Haider Iftikhar) #19

where can i check the version of my ArduSub? but i have installed the latest version that was uploaded on 21st Dec.

no i didnt used a logic converter, i directly connected it to arduino.


(Jacob) #20

The instructions to find the firmware version are in this post: https://www.bluerobotics.com/forums/topic/cant-switch-to-depth-hold-mode/#post-13011

You can download the stable version of ArduSub here. If you are using the BlueROV2, download the ‘vectored’ firmware.

You may have damaged your pressure sensor. The pressure sensor I2C lines are not 5V tolerant. Most Arduinos run I2C at 5V. The Pixhawk I2C port is 3.3V, which is what the Bar30 was designed for.

-Jacob