Home        Store        Learn        Blog

PingViewer problems starting and window position

Hello,
I have some trouble with the Pingviewer Software: The Ping360 is working well, no hardware issues. I installed a second monitor via USB-C to get rid of the pingviewer window in the video-display of the ROV. Somewhen I have minimized or something like this the Pingviewer window and now it seems to be outside any monitor. No chance to get it back in the visible displayarea. I tried all keyboard combinations to move the window. If I press alt+tab I can switch between QGC and Pingviewer but it stays invisible.

So I tried a new installation but after starting I get the message VCRUNTIME140.dll or VCRUNTIME140_1.dll could not be found and the program does not start anymore. The first file does exist in the directory where the exe is, the second not. I know, the first issue is a windows problem but I cant fix it if Pingviewer does not run anymore. Has anyone experienced similar problems?

Thanks for help!

Best regards
Chris

Hey Chris,

I do the same thing showing Pingviewer on a USB monitor. This issue has happened to me. Try hovering your mouse over the icon in the taskbar, then move your mouse over the ‘thumbnail’ image of Pingviewer. Then left click, and choose ‘Move’. You should be able to then use the arrow keys on the keyboard to move the window back to the main screen, or the USB screen.

There’s probably a Windows hack for moving it easier, but this procedure is all I came up with.

Ken

1 Like

Hi @schleitauche,

That’s an issue that should be fixed as of March 2020. If it’s still happening in a recent release then we’d appreciate a GUI Log, and as a temporary workaround it should be fixed if you reset the settings :slight_smile:

I spoke with @patrickelectric and was told Ping Viewer checks for either of those files, and uses the first one it finds. If one of them is there then that issue shouldn’t occur.

There was a new Ping Viewer release (v2.3.0) about 15 minutes before your post. Are you on that one or the one just before it? I just tried 2.3.0 on Windows and Mac and it doesn’t seem to have the issue you mentioned. I don’t believe anyone brought up an issue like this with the previous version either, so perhaps there was some issue when you extracted/installed it. I’m assuming you followed the relevant installation instructions? :slight_smile:

Maybe worth trying again with a fresh 2.3.0 download. If the issue still occurs then please send through your last GUI Log :slight_smile:

2 Likes

Hi Ken, hi Eliot,
thank you very much for the super fast reply!
@k-deboer Thanks for the nice trick, but it doesn’t work with my old version (that is only still running on my ROV tablet-PC). I can see the cursor changing to a 4arrow-icon but theres is still no window below the cursor during moving. It ist completely invisible.

@EliotBR I tried to start the 2.3.0 version, but I still get the DLL-problem (only on my Dell-Tablet-PC with Win10). On my desktop computer everythings fine. The old version starts, but no visible window doesnt allow me to look what version it is…
I tried to edit the main.qml (do I have to?) but I can’t find it. In “deploy” there is no directory “qml” or an file main.qml so I can’t reset the window. Also I don’t know where to find the GUI Log. I searched inside the “deploy”-directory of Pingviewer with no results.

Maybe it has somethnig to do with permissions on my tablet (but why does the older version start?) but I’m logged in as an administrator.

Greets
Chris

Edit: The older, invisible version is 2.1.0, found it in the taskbar-Icon… :slight_smile:

Not sure why that’s happening - I’ve raised it internally and will get back to you with any follow-ups. By “I tried to start the 2.3.0 version” did you mean you just tried opening the one you already had? If so, could you try downloading a new one instead? :slight_smile:

My apologies, I pasted the code fix link twice, instead of the correct link for the ‘reset the settings’ part. I’ve edited my comment so the link should be correct now:

The Folder Structure section is just above the GUI Log section that I linked you to - it should be in your documents folder :slight_smile:

1 Like

@EliotBR
Thanks again, now I found everything. The reset in the registry works well, the window is now visible so I can use my sonar again!
The issue with the DLLs with 2.3.0 is still present. I downloaded it yesterday again after you gave me th hint there is a new release available. There ist no entry of v2.3.0 in the log, only v2.1.0 is able to add txt’s to the log.
But because Pingviewer 2.3.0 runs without issues on my other computer and 2.1.0 runs on my outdoor device, I carry on to find out where the difference is between both installations.
I’m hopeful that can’t be a big thing. I will keep you updated.
Thanks again for the incredible fast support, thank you very much!

Best regards
Chris

1 Like

Great to hear! :slight_smile:

Interesting. Perhaps the DLL check happens before the first GUI Log message location.

It’s still unclear at this point whether it’s a device/setup issue or an actual issue with Ping Viewer, but I’ve filed an issue here so we can at least track it as we find more information :slight_smile:

1 Like

We have met the same problem. This problem only exists in dual display computers, but not all dual display computers have this problem. It seems that the initial screen position of pingviewer conflicts with QGC. I can only distinguish the two interfaces through Win + left arrow key, and then drag the pingview interface to the second screen with the mouse.

Hi @MMMMK,

Is this on a recent version of Ping Viewer (>= v2.2.0)? If it’s 2.1 or earlier then a window being off the screen is a known issue, as discussed above.

This doesn’t sound like a “window off the screen” problem, but rather that your QGC window is in front of Ping Viewer. That’s not something Ping Viewer can be aware of (window relative depth is generally managed by the operating system), but if it’s of interest recent Ping Viewer versions (>= v2.2.0) have an “Always-On-Top” mode that you can enable from the Display Settings if you want to :slight_smile: