Home        Store        Learn        Blog

Error Downloading Ping Viewer to new computer

Keep getting following error every time and every way I download the Ping Viewer Software.

Ping Run Error 2021-12-04 155046

VCRUNTIME140.dll is in the extracted files. Nowhere do I see VCRUNTIME140_1.dll.

I even copied the extracted folder from current running computer and get this same error.

This is a brand new computer updated with latest Windows 10 and only other thing installed currently is QGround Control.

Hi @dtrail,

I had the same with a new computer. I resolved this issue by downloading and installing Microsoft Visual C++ 2015 - 2019 Redistributable

Hope this helps,
Ken

That worked! Thank you very much.

That’s not expected behaviour. Someone had the same issue recently, which I raised at the time in this bug report.

For some context, Ping Viewer is supposed to look for either of those files, and as long as one of them is available it should work.

In the interests of getting this fixed, would both of you be able to specify your device type, in case that’s relevant? The original case was a Dell tablet-PC, so at this point it’s not clear if it’s particular devices, or if it’s an issue on the latest Windows 10 or something.

FYI
My computer.

Intel NUC 8 Performance-G Mini PC (NUC8i7HVKVA) - Core i7 100W, 16GB RAM, 1TB SSD

Hi Eliot,
Mine was a Panasonic CF-31 i5. Windows 10 Pro 64bit
Ken

Great, thanks guys :slight_smile:

Hi, my computer with the same issue is an Dell Tablet i5 8350U 1.7 GHz, Win10 and updated on Win11 yesterday with no effect to this problem. After updating VisualC++ the issue is solved! Thanks very much!

This issue has now been solved, thanks to the hard work of our new software intern @joaoantoniocardoso! :smiley:

The update has been merged into the master branch, but isn’t yet in a release. We’re hoping to make a new Ping Viewer release this week or next, which should include João’s fix :slight_smile:

1 Like