QGroundControl Missing DLL Files

I have similar problem but not sure if caused by antivirus software or not. I am using a new computer given by client and have to download all software for BROV2 use. I was able to download the PingViewer just fine, but when I when I download QGC and open it, I recieve these error messages:



I tried downloading QGC from both the BlueRobotics software page (https://bluerobotics.com/learn/bluerov2-software-setup/)and the github release page (Releases · mavlink/qgroundcontrol · GitHub) but receive the same message. From seeing above, I looked into whether this could be due to a security app, which I found McAfee, but it says the account hasn’t been active for very long time and not being used so this doesn’t seem to be the case.

Also to note when I originally downloaded QGC, it asked for a UAV driver installation which I had to do or else could not continue with downloading QGC, so I did so. And once it did download, it then gave three options to run; QGroundControl, QGroundControl(Compatibility version), QGroundControl (GPU safe version). Something along those lines. I don’t know exactly what the others mean but when I tried running any of them the same error message from above appeared. Could someone maybe have an idea of what is occurring with the download and then trying to run it?

Also I have uninstalled and reinstalled many times to try nd reet it but to no avail.

Hi @Jnyberg,

I brought this up with the software team and was told you

Apparently most computers end up getting them somewhere else, because it’s a prerequisite for a large amount of software on Windows. There used to be a similar issue for Ping Viewer, but we now package the relevant .dll files with the application - seemingly QGC doesn’t do the same.

1 Like

We just did 2 fresh installs on brand new PCs and same dll (vcruntime140_1) was missing. We download the dll file and keep it handy. Placing it in Program Files/Qgroundcontrol folder solves the problem every time.

2 Likes

For those interested, I’ve raised an issue about this now. We’ll have to see whether the core QGC devs decide to bundle the relevant .dll files with the application, or just document their necessity in the installation instructions.

2 Likes