Home        Store        Docs        Blog

Ping Viewer not starting, Windows 10

Hi,

I’ve downloaded the Ping Viewer stable release from

https://github.com/bluerobotics/ping-viewer/releases/download/stable/pingviewer_release.zip

and unzipped it onto two different Windows 10 machines.

I tried to start pingviewer.exe in the deploy subfolder of the extracted directory. The first time I do this, I get a warning screen and choose “Run Anyway.” After that, I get no such warning.

But every time, the program silently dies after creating a new, empty .txt file in Documents/PingViewer/Gui_Log. It is briefly visible in the processes in the Windows Task Manager, like this:

I’m going to check with our managed service provider to make sure it’s not just killing off an unsigned executable named pingviewer.exe because it sounds like a network threat or something, but wondering if there are some outstanding Ping Viewer issues on Win 10.

My echosounder and USB-to-serial adapter appear to work fine using the bluerobotics-ping/ping-python python library, but I’d like to play around with the streaming visualization for initial testing if I can.

Hi Daniel,

That’s really weird, can you finish/kill this others pingviewer.exe and start Ping-Viewer in your terminal ?
Probably there’s a warning or error message before Ping-Viewer starts, that’s why log or any other debug system is not showing up. Can you copy in your file explorer the executable file and paste it in your powershell terminal between double quotes ? E.g:
> "C:/Downloads/Ping/pingviewer.exe"
If there is no output, probably your antivirus or security system is scanning or doing something with our application.

No output at all. In PowerShell:

PS C:\WINDOWS\system32> "C:/Users/<username>/bin/pingviewer/deploy/pingviewer.exe"
C:/Users/<username>/bin/pingviewer/deploy/pingviewer.exe

That’s it, and it doesn’t even show up briefly in Task Manager. The screenshot above is for approximately 1 second before the process disappears, and only if I double-click the executable.

Same result in an ordinary command shell.

I think my MSP will probably contact me soon if it’s something that they’re monitoring and killing :slight_smile:

Also: in PowerShell if I type the full path without quotes, a new empty text file is generated in Gui_Log, but NOT if I do it with the quotes:

Causes a .txt file to appear:

PS C:\Users<username>\bin\pingviewer\deploy>C:/Users/<username>/bin/pingviewer/deploy/pingviewer.exe

Does not cause a text file to appear:

PS C:\Users\<username>\bin\pingviewer\deploy>"C:/Users/<username>/bin/pingviewer/deploy/pingviewer.exe"
C:/Users/<username>/bin/pingviewer/deploy/pingviewer.exe

Can you please upload the log file? Is there any content in the GUI log, or sensor log?

All Gui_Log files are empty, no files were ever generated in Sensor_Log

We haven’t encountered any issues on other installations. Please let us know what your MSP says about the unsigned executable.

Will do!