PingViewer not responding

As the title mentions, I am having trouble setting up PingViewer. I have installed a Ping360 and Ping Altimeter on a BlueROV2. The devices are shown on the systems page and do show up on PingViewer when I open the program, however when I try and do anything with the program it immediately stops responding and, even after leaving it for several minutes, nothing happened.
I have also installed the viewer on a different laptop, with the same results.

Hi @RossAspect, welcome to the forum :slight_smile:

A few questions:

  1. Are you saying that when you click on a device name to connect to it, it doesn’t start plotting the scans?
  2. Are you on the recommended versions of Ping Viewer and Companion?
  3. Do one or both of the sonars work properly when connected directly to the computer running Ping Viewer, instead of via the ROV?

Hi @EliotBR thanks for the welcome,
To answer

  1. When I click on a device to connect, it doesn’t plot anything and if fact locks up and goes to ‘not responding’.
  2. I’m using recommended versions of both Ping-Viewer and Companion.
  3. The Ping1D connects and shows up properly while connected to my the computer, the Ping360 does not appear at all, even after following all of the troubleshooting steps.

Since I posted I have also tried connecting only one at a time to try and see if it was only one of the devices that might be causing the fault, but the behaviour repeated itself. I have also connected to the ROV directly, bypassing the Fathom-X, but it still didn’t work.

Hmm, that’s odd. Are you able to provide a GUI Log from when that happens?

A couple more questions:

  1. Which operating system are you using?
  2. Which configuration is your Ping360 in (e.g. USB / Ethernet)?

20220302-130140634.txt (65.0 KB)
One of the GUI logs, as requested.

  1. Both of the computers I have tried are using Windows 10.
  2. The Ping360 is in USB configuration, using the JST-GH to JST-GH inline connection board into the RPi.

    The view on 192.168.2.2:2270/system.

Thanks for providing that info :slight_smile:

Your setup seems fine, and from your screenshot the Companion software looks to be detecting both devices. The log file you provided seems to be repeatedly detecting the Ping360, but not the Ping Sonar.

I asked our main Ping Viewer developer if he had any ideas, and apparently

I’ve just tried using 2.3.1 and it is displaying the same behaviour as 2.3.3.

I just checked on the wait chains for PingViewer while it was not responding and it lists that is waiting on dwm.exe and svchost.exe.
waitchains

Hi all,

Just finished putting together 2 new BlueROVs with pingers. I’ve managed to get both pingers working fine (at least until I can get in the water and see if they’re accurate), but I’m running into trouble on the software fine. When I load up Ping Viewer, it detects the Pinger almost instantly but then it’s very difficult to connect to it (i.e. click on the IP address). The software seems to be in an infinite loop, and doesn’t quite crash, but interacting with the interface becomes almost impossible. Occasionally the software gets out of this loop and into the pinger interface fine, but it’s not reliable and a bit of a pain in the butt. Has anyone else run into this? I’ve got the latest version of the software and I assume the pinger (since it was sent a month or so ago) should have recent firmware as well.

@RossAspect thanks for checking that, and for the extra details. @patrickelectric has said he’ll try to sort out the issue tomorrow :slight_smile:

@Vincent we’ve had a couple of similar reports in the past few days. Are you on Windows? We currently suspect a recent Windows update may have caused some issues with the Ping Viewer functionality.

I’m having the same issue with the Ping360. Windows with 2.3.3.

Yes, this is through Windows 10. It does sometimes work, and once data starts coming in it seems to work smoothly, but it’s very hit and miss whether it gets to that stage.

Hi,

I was able to replicate the issue on version v2.3.1-v2.3.3, can you try the latest v2.2 release or v2.3.0 ? It appears to be working and it can be a workaround while a v2.3.4 is not released with the fix.

v2.3.0 works for me. (Windows 10 and Ping360)

There is a candidate that should fix the issue here, can you try it ?
The PR for such binary is available here:

@patrickelectric This new test version works for me - although it reads v2.3.0 on the menu bar.

That’s a bit weird, I have updated the zip file again to make sure, on the info page you should see something like:
image

I’m not sure what happened. Seems to be working now.

@patrickelectric Can confirm that it is also working for me as well. Thank you for the help with this problem.

1 Like

The latest version, v2.3.4 has the fix and is the new stable version of Ping-Viewer, thanks for reporting and helping with the tests.

1 Like

Latest version seems to have fixed it for me. Thanks!

1 Like