Home        Store        Docs        Blog

Pinger no communication

Hello BlueRobotics!

I’m having some issues with the pinger and need some assistance. Searched the forums and haven’t found a solution.

When I bought the BlueRov, I installed the pinger and used it for 3 dives. The other inspections I did after that didn’t require me to use it so I didn’t start ping viewer for several dives and then I removed the pinger. Now I have a project coming up there I need it again.

I’ve got a new laptop for running the BlueRov. I’ve installed all the software but it does not show up in the ping viewer. There are no serial port available in the drop down menu and no connection can be established via UDP to 192.168.2.2 port 9090/9092.

Everything else works great on the ROV.

Tests so far:

Installed CDM21228_Setup from your website.

Checked all cable connections inside bottle.

Checked continuity of cables from pinger r/w/g/b to the BLUART serial adapter with multimeter, no problem.

Changed USB cable (bought 2 from you, one as a spare) and 2 different USB ports.

Tried on other computers (incl old laptop).

Companion version is 0.0.17 and have tried a reset.

Latest version of ping viewer downloaded from your website.

The green led on the BLUART serial adapter lightens up when connecting battery.

What else can I try or might the pinger be busted?

Many thanks,

Linus

Hi Linus,

Can you connect Ping directly in your surface computer with the USB/serial adapter ?
Ping-Viewer should be able to detect the serial port and connect with Ping.

Hello Patrick,

When I connect it straight to the PC and start ping viewer I get indication on TX/RX + the serial port pops up (did not do that when running via ROV).
Loop of TX only, TX+RX,TX+RX.

No data showing up in the waterfall though.

I can’t do any changes in the Ping window. If I go to settings and use a drop down menu to select the same serial port or the same baudrate again, I can start pinging in the Ping window. No data shows up in waterfall but I get a steady 1Hz TX/RX pulse and also a TX/TX if I hit “Emit ping”.

Nothing happens if I look for firmware, just a continuous search.

No luck with UDP either.

Under information, device, model etc is 0.

Thanks,
Linus

Hi Linus,

Check if the LED is blinking and if the 4 cables [red, black, white, green] are not broken with a multimeter. If everything appears to be right, I would recommend to flash the firmware following the instructions below: