Nonsensical Arduino serial outputs, no connection on PingViewer

Hi team, hoping I can get some help pretty urgently.
Have tried connecting a Ping 1D sonar over the RS485 to serial adapter to two different computers, both running Windows 10. In both cases, the PingViewer application is unable to detect the devices automatically. I can tell what serial port the Ping is connected to, because it disappears when I disconnect the USB port. Manual connection does not work either.

As a second option, I’ve tried connecting using an Arduino Uno with the supplied library, and running the ping1d-simple example sketch. I get the following output over the serial terminal, which doesn’t really make sense to me:

Any help would be hugely appreciated, because I’m running out of ideas.
Thanks

Update: changed the baudrate of the Arduino terminal to 115200 and I’m getting some sensible values at last. Still no luck with PingViewer however.

Hi @Jawsh, welcome to the forum :slight_smile:

Sorry to hear you’re having issues connecting with your Ping Sonar.

Have you tried our Ping Viewer Troubleshooting steps? Given you’ve confirmed the device to be working, I expect you may need to install / update your computer’s FTDI drivers, or there could be some issue with your USB-serial adaptor and/or your USB cable.

It may be helpful to check whether a device appears in the COM port list when it’s plugged in, and perhaps to try on a different computer to confirm whether the adaptor and cable are working as expected.